Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "ModemManager is a daemon controlling broadband devices/connections" |
| 2 | DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections" |
| 3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/" |
| 4 | LICENSE = "GPL-2.0 & LGPL-2.1" |
| 5 | LIC_FILES_CHKSUM = " \ |
| 6 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 7 | file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \ |
| 8 | " |
| 9 | |
| 10 | inherit gnomebase gettext systemd vala gobject-introspection bash-completion |
| 11 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 12 | DEPENDS = "glib-2.0 libgudev intltool-native libxslt-native" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | |
| 14 | SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz \ |
| 15 | " |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 16 | SRC_URI[md5sum] = "92d25176d0cc9d588ca29700b33c7d98" |
| 17 | SRC_URI[sha256sum] = "fd0f39996025dac96995daea8a58ec7dd571582f7563a8ae0d5f65b571b76ee2" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | |
| 19 | S = "${WORKDIR}/ModemManager-${PV}" |
| 20 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | PACKAGECONFIG ??= "mbim qmi \ |
| 22 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd polkit', d)} \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | " |
| 24 | |
| 25 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,," |
| 26 | PACKAGECONFIG[polkit] = "--with-polkit=yes,--with-polkit=no,polkit" |
| 27 | # Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol. |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | PACKAGECONFIG[mbim] = "--with-mbim,--without-mbim,libmbim" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | # Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol. |
| 30 | PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi" |
| 31 | |
| 32 | EXTRA_OECONF = " \ |
| 33 | --with-udev-base-dir=${nonarch_base_libdir}/udev \ |
| 34 | " |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 35 | EXTRA_OECONF_append_toolchain-clang = " --enable-more-warnings=no" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 36 | |
| 37 | FILES_${PN} += " \ |
| 38 | ${datadir}/icons \ |
| 39 | ${datadir}/polkit-1 \ |
| 40 | ${datadir}/dbus-1 \ |
| 41 | ${libdir}/ModemManager \ |
| 42 | ${systemd_unitdir}/system \ |
| 43 | " |
| 44 | |
| 45 | FILES_${PN}-dev += " \ |
| 46 | ${libdir}/ModemManager/*.la \ |
| 47 | " |
| 48 | |
| 49 | FILES_${PN}-staticdev += " \ |
| 50 | ${libdir}/ModemManager/*.a \ |
| 51 | " |
| 52 | |
| 53 | FILES_${PN}-dbg += "${libdir}/ModemManager/.debug" |
| 54 | |
| 55 | SYSTEMD_SERVICE_${PN} = "ModemManager.service" |