Brad Bishop | dd12ede | 2019-05-13 14:46:48 -0400 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" |
Matthew Barth | 035b616 | 2020-01-14 14:21:46 -0600 | [diff] [blame] | 2 | |
| 3 | SRC_URI_witherspoon = "file://config.json" |
Adriana Kobylak | 6234872 | 2021-03-25 16:40:34 +0000 | [diff] [blame] | 4 | SRC_URI_p10bmc = "file://rainier-2u/config.json \ |
Matthew Barth | 530e1d8 | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 5 | file://rainier-4u/config.json \ |
Andrew Geissler | db94adf | 2021-03-23 18:54:59 -0500 | [diff] [blame] | 6 | file://rainier-1s4u/config.json \ |
Matthew Barth | 530e1d8 | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 7 | file://everest/config.json \ |
| 8 | " |
Matthew Barth | 035b616 | 2020-01-14 14:21:46 -0600 | [diff] [blame] | 9 | |
| 10 | do_install_witherspoon() { |
| 11 | install -d ${D}/${datadir}/phosphor-fan-presence/presence/ |
| 12 | install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ |
| 13 | } |
Adriana Kobylak | 6234872 | 2021-03-25 16:40:34 +0000 | [diff] [blame] | 14 | do_install_p10bmc() { |
Matthew Barth | 530e1d8 | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 15 | # Install Rainier-2U/4U fan presence config files |
| 16 | install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/ |
| 17 | install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/ |
Andrew Geissler | db94adf | 2021-03-23 18:54:59 -0500 | [diff] [blame] | 18 | install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/ |
Matthew Barth | 530e1d8 | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 19 | install -m 0644 ${WORKDIR}/rainier-2u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/ |
| 20 | install -m 0644 ${WORKDIR}/rainier-4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/ |
Andrew Geissler | db94adf | 2021-03-23 18:54:59 -0500 | [diff] [blame] | 21 | install -m 0644 ${WORKDIR}/rainier-1s4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/ |
Matthew Barth | 530e1d8 | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 22 | |
| 23 | # Install Everest fan presence config file |
| 24 | install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/ |
| 25 | install -m 0644 ${WORKDIR}/everest/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/ |
| 26 | } |
Matthew Barth | 035b616 | 2020-01-14 14:21:46 -0600 | [diff] [blame] | 27 | |
| 28 | FILES_${PN}_append_witherspoon = " ${datadir}/phosphor-fan-presence/presence/config.json" |
| 29 | FILES_${PN}_remove_witherspoon = "${presence_datadir}/config.yaml" |
Matthew Barth | 530e1d8 | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 30 | |
Adriana Kobylak | 6234872 | 2021-03-25 16:40:34 +0000 | [diff] [blame] | 31 | FILES_${PN}_remove_p10bmc = "${presence_datadir}/config.yaml" |
| 32 | FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/config.json" |
| 33 | FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/config.json" |
| 34 | FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/config.json" |
| 35 | FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,everest/config.json" |