Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "matplotlib: plotting with Python" |
| 2 | DESCRIPTION = "\ |
| 3 | Matplotlib is a Python 2D plotting library which produces \ |
| 4 | publication-quality figures in a variety of hardcopy formats \ |
| 5 | and interactive environments across platforms." |
| 6 | HOMEPAGE = "https://github.com/matplotlib/matplotlib" |
| 7 | SECTION = "devel/python" |
| 8 | LICENSE = "PSF" |
| 9 | LIC_FILES_CHKSUM = "\ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 10 | file://setup.py;beginline=259;endline=259;md5=e0ef37de7122ce842bcd1fb54482b353 \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \ |
| 12 | " |
| 13 | DEPENDS = "\ |
| 14 | freetype \ |
| 15 | libpng \ |
| 16 | python3-numpy-native \ |
| 17 | python3-dateutil-native \ |
| 18 | python3-pytz-native \ |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 19 | python3-certifi-native \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | " |
| 21 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 22 | SRC_URI[md5sum] = "a85791908e78818bd425ba9ab38500fa" |
| 23 | SRC_URI[sha256sum] = "3d2edbf59367f03cd9daf42939ca06383a7d7803e3993eb5ff1bee8e8a3fbb6b" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | |
| 25 | inherit pypi setuptools3 pkgconfig |
| 26 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 27 | # LTO with clang needs lld |
| 28 | LDFLAGS_append_toolchain-clang = " -fuse-ld=lld" |
| 29 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 30 | RDEPENDS_${PN} = "\ |
| 31 | freetype \ |
| 32 | libpng \ |
| 33 | python3-numpy \ |
| 34 | python3-pyparsing \ |
| 35 | python3-cycler \ |
| 36 | python3-dateutil \ |
| 37 | python3-kiwisolver \ |
| 38 | python3-pytz \ |
| 39 | " |
| 40 | |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 41 | ENABLELTO_toolchain-clang_riscv64 = "echo enable_lto = False >> ${S}/setup.cfg" |
| 42 | ENABLELTO_toolchain-clang_riscv32 = "echo enable_lto = False >> ${S}/setup.cfg" |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 43 | do_compile_prepend() { |
| 44 | echo [libs] > ${S}/setup.cfg |
| 45 | echo system_freetype = true >> ${S}/setup.cfg |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 46 | ${ENABLELTO} |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 47 | } |
| 48 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 49 | BBCLASSEXTEND = "native" |