Brad Bishop | 3077a7f | 2017-01-12 21:44:51 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenBMC - Applications" |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 2 | PR = "r1" |
| 3 | |
| 4 | inherit packagegroup |
| 5 | inherit obmc-phosphor-utils |
| 6 | inherit obmc-phosphor-license |
| 7 | |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 8 | PROVIDES = "${PACKAGES}" |
| 9 | PACKAGES = " \ |
Brad Bishop | db32a7c | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 10 | ${PN}-bmc-state-mgmt \ |
| 11 | ${PN}-chassis-state-mgmt \ |
Brad Bishop | a242937 | 2016-09-06 22:44:21 -0400 | [diff] [blame] | 12 | ${PN}-extras \ |
| 13 | ${PN}-extrasdev \ |
Adriana Kobylak | 6adca3a | 2017-11-09 10:39:02 -0600 | [diff] [blame] | 14 | ${PN}-extrasdevtools \ |
Brad Bishop | 4824d4c | 2017-05-01 11:54:34 -0400 | [diff] [blame] | 15 | ${PN}-fan-control \ |
Brad Bishop | db32a7c | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 16 | ${PN}-host-state-mgmt \ |
Brad Bishop | 4f12f72 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 17 | ${PN}-inventory \ |
| 18 | ${PN}-leds \ |
| 19 | ${PN}-sensors \ |
Gunnar Mills | 058788a | 2017-02-15 16:01:45 -0600 | [diff] [blame] | 20 | ${PN}-software \ |
Andrew Geissler | b1afecc | 2017-05-08 15:58:01 -0500 | [diff] [blame] | 21 | ${PN}-host-check-mgmt \ |
Jayanth Othayoth | 9be81b1 | 2017-05-08 09:25:05 -0500 | [diff] [blame] | 22 | ${PN}-debug-collector \ |
Deepak Kodihalli | feb8867 | 2017-05-17 06:42:51 -0500 | [diff] [blame] | 23 | ${PN}-settings \ |
Ratan Gupta | d3c6164 | 2017-07-06 21:09:14 +0530 | [diff] [blame] | 24 | ${PN}-network \ |
Vishwanatha Subbanna | 0ea6f63 | 2017-10-18 15:47:54 +0530 | [diff] [blame] | 25 | ${PN}-user-mgmt \ |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 26 | " |
| 27 | |
Brad Bishop | db32a7c | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 28 | SUMMARY_${PN}-bmc-state-mgmt = "BMC state management" |
| 29 | RDEPENDS_${PN}-bmc-state-mgmt = " \ |
| 30 | ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \ |
| 31 | " |
| 32 | |
| 33 | SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management" |
| 34 | RDEPENDS_${PN}-chassis-state-mgmt = " \ |
| 35 | ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \ |
| 36 | " |
| 37 | |
Andrew Geissler | b1afecc | 2017-05-08 15:58:01 -0500 | [diff] [blame] | 38 | SUMMARY_${PN}-host-check-mgmt = "Host state check on bmc reset" |
| 39 | RDEPENDS_${PN}-host-check-mgmt = " \ |
| 40 | ${VIRTUAL-RUNTIME_obmc-host-check} \ |
| 41 | " |
| 42 | |
Brad Bishop | a242937 | 2016-09-06 22:44:21 -0400 | [diff] [blame] | 43 | SUMMARY_${PN}-extras = "Extra features" |
| 44 | RDEPENDS_${PN}-extras = " \ |
Brad Bishop | 3077a7f | 2017-01-12 21:44:51 -0500 | [diff] [blame] | 45 | phosphor-rest \ |
Brad Bishop | 0f547b1 | 2017-05-31 14:08:33 -0400 | [diff] [blame] | 46 | phosphor-dbus-monitor \ |
Brad Bishop | 70436da | 2015-09-16 14:49:27 -0400 | [diff] [blame] | 47 | " |
| 48 | |
Brad Bishop | a242937 | 2016-09-06 22:44:21 -0400 | [diff] [blame] | 49 | SUMMARY_${PN}-extrasdev = "Development features" |
| 50 | RDEPENDS_${PN}-extrasdev = " \ |
Adriana Kobylak | a3e925f | 2016-06-16 14:46:06 -0500 | [diff] [blame] | 51 | rest-dbus \ |
| 52 | " |
Brad Bishop | 4f12f72 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 53 | |
Adriana Kobylak | 6adca3a | 2017-11-09 10:39:02 -0600 | [diff] [blame] | 54 | SUMMARY_${PN}-extrasdevtools = "Development tools" |
| 55 | RDEPENDS_${PN}-extrasdevtools = " \ |
| 56 | " |
| 57 | |
Brad Bishop | 4824d4c | 2017-05-01 11:54:34 -0400 | [diff] [blame] | 58 | # Use the fan control package group for applications |
| 59 | # implementing fan control or system fan policy only. |
| 60 | # Applications that create inventory or sensors should |
| 61 | # be added those respective package groups instead. |
| 62 | SUMMARY_${PN}-fan-control = "Fan control" |
| 63 | RDEPENDS_${PN}-fan-control = " \ |
Matt Spinler | c133ec1 | 2017-04-19 08:23:50 -0500 | [diff] [blame] | 64 | ${VIRTUAL-RUNTIME_obmc-fan-control} \ |
Matt Spinler | dd7a080 | 2017-05-01 14:29:20 -0500 | [diff] [blame] | 65 | phosphor-fan-monitor \ |
Brad Bishop | 4824d4c | 2017-05-01 11:54:34 -0400 | [diff] [blame] | 66 | " |
| 67 | |
Brad Bishop | db32a7c | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 68 | SUMMARY_${PN}-host-state-mgmt = "Host state management" |
| 69 | RDEPENDS_${PN}-host-state-mgmt = " \ |
| 70 | ${VIRTUAL-RUNTIME_obmc-host-state-manager} \ |
Michael Tritz | b3b5899 | 2017-03-31 12:04:32 -0500 | [diff] [blame] | 71 | ${VIRTUAL-RUNTIME_obmc-discover-system-state} \ |
Brad Bishop | db32a7c | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 72 | " |
| 73 | |
Brad Bishop | 4f12f72 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 74 | SUMMARY_${PN}-inventory = "Inventory applications" |
| 75 | RDEPENDS_${PN}-inventory = " \ |
| 76 | ${VIRTUAL-RUNTIME_obmc-inventory-manager} \ |
Matthew Barth | acd9fe4 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 77 | ${VIRTUAL-RUNTIME_obmc-fan-presence} \ |
Brad Bishop | 4f12f72 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 78 | " |
| 79 | |
| 80 | SUMMARY_${PN}-leds = "LED applications" |
| 81 | RDEPENDS_${PN}-leds = " \ |
Brad Bishop | af7d060 | 2017-02-27 11:59:49 -0500 | [diff] [blame] | 82 | ${VIRTUAL-RUNTIME_obmc-leds-manager} \ |
| 83 | ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \ |
Dhruvaraj Subhashchandran | 6a1b0fc | 2017-04-27 05:29:56 -0500 | [diff] [blame] | 84 | ${VIRTUAL-RUNTIME_obmc-led-monitor} \ |
Brad Bishop | 4f12f72 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 85 | " |
| 86 | |
| 87 | SUMMARY_${PN}-sensors = "Sensor applications" |
| 88 | RDEPENDS_${PN}-sensors = " \ |
| 89 | ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \ |
| 90 | " |
Gunnar Mills | 058788a | 2017-02-15 16:01:45 -0600 | [diff] [blame] | 91 | |
| 92 | SUMMARY_${PN}-software = "Software applications" |
| 93 | RDEPENDS_${PN}-software = " \ |
Deepak Kodihalli | b74ceea | 2017-04-13 23:23:42 -0500 | [diff] [blame] | 94 | ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \ |
Gunnar Mills | cfe0084 | 2017-05-15 15:40:58 -0500 | [diff] [blame] | 95 | ${VIRTUAL-RUNTIME_obmc-bmc-updater} \ |
Andrew Geissler | a30470f | 2018-02-09 12:50:57 -0800 | [diff] [blame^] | 96 | ${VIRTUAL-RUNTIME_obmc-bmc-version} \ |
Gunnar Mills | 058788a | 2017-02-15 16:01:45 -0600 | [diff] [blame] | 97 | " |
Andrew Geissler | a30470f | 2018-02-09 12:50:57 -0800 | [diff] [blame^] | 98 | # Determine if the non-UBI flash packages are required |
| 99 | RDEPENDS_${PN}-software += " \ |
| 100 | ${@mf_enabled(d, 'obmc-ubi-fs', \ |
| 101 | '', \ |
| 102 | 'obmc-flash-bmc obmc-mgr-download')} \ |
| 103 | " |
| 104 | |
Jayanth Othayoth | 9be81b1 | 2017-05-08 09:25:05 -0500 | [diff] [blame] | 105 | SUMMARY_${PN}-debug-collector = "BMC debug collector" |
| 106 | RDEPENDS_${PN}-debug-collector = " \ |
Jayanth Othayoth | 2a5d91e | 2017-05-31 06:25:55 -0500 | [diff] [blame] | 107 | ${VIRTUAL-RUNTIME_obmc-dump-manager} \ |
| 108 | ${VIRTUAL-RUNTIME_obmc-dump-monitor} \ |
Jayanth Othayoth | f4e6607 | 2017-07-29 22:28:44 -0500 | [diff] [blame] | 109 | phosphor-debug-collector-dreport \ |
Marri Devender Rao | b6e5cb0 | 2017-10-11 02:22:46 -0500 | [diff] [blame] | 110 | phosphor-debug-collector-scripts \ |
Vishwanatha Subbanna | dfd5bf3 | 2017-05-12 23:31:55 +0530 | [diff] [blame] | 111 | " |
Deepak Kodihalli | feb8867 | 2017-05-17 06:42:51 -0500 | [diff] [blame] | 112 | |
| 113 | SUMMARY_${PN}-settings = "Settings applications" |
| 114 | RDEPENDS_${PN}-settings = " \ |
| 115 | ${VIRTUAL-RUNTIME_obmc-settings-mgr} \ |
| 116 | " |
Ratan Gupta | d3c6164 | 2017-07-06 21:09:14 +0530 | [diff] [blame] | 117 | |
| 118 | SUMMARY_${PN}-network = "BMC Network Manager" |
| 119 | RDEPENDS_${PN}-network = " \ |
| 120 | ${VIRTUAL-RUNTIME_obmc-network-manager} \ |
| 121 | " |
Vishwanatha Subbanna | 0ea6f63 | 2017-10-18 15:47:54 +0530 | [diff] [blame] | 122 | |
| 123 | SUMMARY_${PN}-user-mgmt = "User management applications" |
| 124 | RDEPENDS_${PN}-user-mgmt = " \ |
| 125 | ${VIRTUAL-RUNTIME_obmc-user-mgmt} \ |
| 126 | " |