blob: a30a3e46c099ed796a10d610a5acd34cc0e86674 [file] [log] [blame]
Andrew Geissler82cfa662020-02-17 15:11:03 -06001SUMMARY = "OpenPOWER processor control services installation"
2PR = "r1"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit allarch
8
9RDEPENDS_${PN} += "op-proc-control"
10RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets"
11
12ALLOW_EMPTY_${PN} = "1"
13
14pkg_postinst_${PN}() {
Andrew Geissler55bd4492020-03-31 13:43:46 -050015 mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.wants
Andrew Geissler82cfa662020-02-17 15:11:03 -060016 mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
Dhruvaraj Subhashchandranc8aa6a12020-03-09 13:04:32 -050017 mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
18 mkdir -p $D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires
Andrew Geisslerf95063e2020-04-14 15:08:43 -050019 mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires
Andrew Geisslerc3f1beb2020-12-09 15:05:02 -060020 mkdir -p $D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants
Andrew Geissler82cfa662020-02-17 15:11:03 -060021
Andrew Geissler55bd4492020-03-31 13:43:46 -050022 LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -060023 TARGET="../op-stop-instructions@.service"
24 ln -s $TARGET $LINK
25
Andrew Geisslerc3f1beb2020-12-09 15:05:02 -060026 LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/op-stop-instructions@0.service"
27 TARGET="../op-stop-instructions@.service"
28 ln -s $TARGET $LINK
29
Andrew Geisslerf95063e2020-04-14 15:08:43 -050030 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service"
31 TARGET="../op-cfam-reset.service"
32 ln -s $TARGET $LINK
33
34 LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -060035 TARGET="../op-cfam-reset.service"
36 ln -s $TARGET $LINK
Andrew Geissler4e174d12020-02-26 14:11:53 -060037
38 # Only install cfam override if p9 system
39 if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then
40 mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
41 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service"
42 TARGET="../cfam_override@.service"
43 ln -s $TARGET $LINK
44 fi
Dhruvaraj Subhashchandranc8aa6a12020-03-09 13:04:32 -050045
46 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
47 TARGET="../op-continue-mpreboot@.service"
48 ln -s $TARGET $LINK
49
Andrew Geissler88eef192020-12-17 11:37:11 -060050 # Only install certain units if phal enabled
Ramesh Iyyard6d9b542020-09-17 10:02:08 -050051 if [ "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" = phal ]; then
52 mkdir -p $D$systemd_system_unitdir/obmc-host-start@0.target.requires
53 LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
54 TARGET="../phal-reinit-devtree.service"
55 ln -s $TARGET $LINK
Chirag Sharma5ec16a32020-12-11 03:45:15 -060056
57 LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
58 TARGET="../proc-pre-poweroff@.service"
59 ln -s $TARGET $LINK
Andrew Geissler4d2fd8d2021-06-24 15:28:47 -050060
61 LINK="$D$systemd_system_unitdir/obmc-host-reset@0.target.requires/op-reset-host-check@0.service"
62 TARGET="../op-reset-host-check@.service"
63 ln -s $TARGET $LINK
Jayanth Othayothad68ba32021-07-30 06:35:44 -050064
65 mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
66 LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service"
67 TARGET="../phal-import-devtree@.service"
68 ln -s $TARGET $LINK
69 fi
Andrew Geissler88eef192020-12-17 11:37:11 -060070
Andrew Geissleraa25e2c2021-02-01 14:14:25 -060071 # If the memory preserving reboot feature is enabled, set it up
72 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'mpreboot', d)}" = mpreboot ]; then
73 # on mpreboot systems, obmc-host-crash@.target is used for mpreboot
Andrew Geissler88eef192020-12-17 11:37:11 -060074 mkdir -p $D$systemd_system_unitdir/obmc-host-crash@0.target.requires
75 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-force-warm-reboot@0.target"
76 TARGET="../obmc-host-force-warm-reboot@.target"
77 ln -s $TARGET $LINK
78
79 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/op-enter-mpreboot@0.service"
80 TARGET="../op-enter-mpreboot@.service"
81 ln -s $TARGET $LINK
82
Andrew Geissleraa25e2c2021-02-01 14:14:25 -060083 # ensure diagnostic mode is shown for MPREBOOT
Andrew Geissler88eef192020-12-17 11:37:11 -060084 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-diagnostic-mode@0.target"
85 TARGET="../obmc-host-diagnostic-mode@.target"
86 ln -s $TARGET $LINK
87 else
Andrew Geissleraa25e2c2021-02-01 14:14:25 -060088 # If not a mpreboot system, default to quiesce target in crash target to support
Andrew Geissler88eef192020-12-17 11:37:11 -060089 # older system designs like witherspoon
90 mkdir -p $D$systemd_system_unitdir/obmc-host-crash@0.target.wants
91 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.wants/obmc-host-quiesce@0.target"
92 TARGET="../obmc-host-quiesce@.target"
93 ln -s $TARGET $LINK
Ramesh Iyyard6d9b542020-09-17 10:02:08 -050094 fi
Andrew Geissler82cfa662020-02-17 15:11:03 -060095}
96
97pkg_prerm_${PN}() {
Andrew Geissler55bd4492020-03-31 13:43:46 -050098 LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -060099 rm $LINK
Andrew Geisslerf95063e2020-04-14 15:08:43 -0500100 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service"
101 rm $LINK
102 LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -0600103 rm $LINK
Andrew Geissler4e174d12020-02-26 14:11:53 -0600104 # Only uninstall cfam override if p9 system
105 if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then
106 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service"
107 rm $LINK
108 fi
Dhruvaraj Subhashchandranc8aa6a12020-03-09 13:04:32 -0500109 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
110 rm $LINK
Ramesh Iyyard6d9b542020-09-17 10:02:08 -0500111
Andrew Geissler88eef192020-12-17 11:37:11 -0600112 # Remove phal specific units if enabled
Ramesh Iyyard6d9b542020-09-17 10:02:08 -0500113 if [ "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" = phal ]; then
114 LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
115 rm $LINK
Chirag Sharma5ec16a32020-12-11 03:45:15 -0600116
117 LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
118 rm $LINK
Jayanth Othayothad68ba32021-07-30 06:35:44 -0500119
120 LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service"
121 rm $LINK
Andrew Geissleraa25e2c2021-02-01 14:14:25 -0600122 fi
Andrew Geissler88eef192020-12-17 11:37:11 -0600123
Andrew Geissleraa25e2c2021-02-01 14:14:25 -0600124 # Remove mpreboot specific units if enabled
125 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'mpreboot', d)}" = mpreboot ]; then
Andrew Geissler88eef192020-12-17 11:37:11 -0600126 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-force-warm-reboot@0.target"
127 rm $LINK
128
129 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/op-enter-mpreboot@0.service"
130 rm $LINK
131 else
132 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.wants/obmc-host-quiesce@0.target"
133 rm $LINK
Ramesh Iyyard6d9b542020-09-17 10:02:08 -0500134 fi
Andrew Geissler82cfa662020-02-17 15:11:03 -0600135}