Brad Bishop | dd12ede | 2019-05-13 14:46:48 -0400 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" |
Matthew Barth | 8daae52 | 2020-06-19 13:48:27 -0500 | [diff] [blame] | 2 | |
Matthew Barth | 2ae06d6 | 2020-06-22 11:14:20 -0500 | [diff] [blame] | 3 | SRC_URI_witherspoon = "file://config.json" |
Adriana Kobylak | 6234872 | 2021-03-25 16:40:34 +0000 | [diff] [blame] | 4 | SRC_URI_p10bmc = "file://rainier-2u/config.json \ |
Matthew Barth | 530e1d8 | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 5 | file://rainier-4u/config.json \ |
Andrew Geissler | 1053e1e | 2021-03-23 15:49:28 -0500 | [diff] [blame] | 6 | file://rainier-1s4u/config.json \ |
Matthew Barth | 530e1d8 | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 7 | file://everest/config.json \ |
| 8 | " |
Matthew Barth | 8daae52 | 2020-06-19 13:48:27 -0500 | [diff] [blame] | 9 | |
Matthew Barth | 2ae06d6 | 2020-06-22 11:14:20 -0500 | [diff] [blame] | 10 | do_install_witherspoon() { |
Matthew Barth | 8daae52 | 2020-06-19 13:48:27 -0500 | [diff] [blame] | 11 | install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ |
| 12 | install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ |
| 13 | } |
| 14 | |
Adriana Kobylak | 6234872 | 2021-03-25 16:40:34 +0000 | [diff] [blame] | 15 | do_install_p10bmc() { |
Matthew Barth | 530e1d8 | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 16 | # Install Rainier-2U/4U fan monitor config files |
| 17 | install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-2u/ |
| 18 | install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-4u/ |
Andrew Geissler | 1053e1e | 2021-03-23 15:49:28 -0500 | [diff] [blame] | 19 | install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-1s4u/ |
Matthew Barth | 530e1d8 | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 20 | install -m 0644 ${WORKDIR}/rainier-2u/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-2u/ |
| 21 | install -m 0644 ${WORKDIR}/rainier-4u/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-4u/ |
Andrew Geissler | 1053e1e | 2021-03-23 15:49:28 -0500 | [diff] [blame] | 22 | install -m 0644 ${WORKDIR}/rainier-1s4u/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-1s4u/ |
Matthew Barth | 530e1d8 | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 23 | |
| 24 | # Install Everest fan monitor config file |
| 25 | install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,everest/ |
| 26 | install -m 0644 ${WORKDIR}/everest/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,everest/ |
| 27 | } |
| 28 | |
Matthew Barth | 2ae06d6 | 2020-06-22 11:14:20 -0500 | [diff] [blame] | 29 | FILES_${PN}_append_witherspoon = " ${datadir}/phosphor-fan-presence/monitor/config.json" |
| 30 | FILES_${PN}_remove_witherspoon = "${monitor_datadir}/monitor.yaml" |
Matthew Barth | 530e1d8 | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 31 | |
Adriana Kobylak | 6234872 | 2021-03-25 16:40:34 +0000 | [diff] [blame] | 32 | FILES_${PN}_remove_p10bmc = "${monitor_datadir}/monitor.yaml" |
| 33 | FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,rainier-2u/config.json" |
| 34 | FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,rainier-4u/config.json" |
| 35 | FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,rainier-1s4u/config.json" |
| 36 | FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,everest/config.json" |