blob: 2c15e034a9c14fa41d394303d365465ac171c1ad [file] [log] [blame]
Brad Bishopdd12ede2019-05-13 14:46:48 -04001FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
Matthew Barth8daae522020-06-19 13:48:27 -05002
Matthew Barth2ae06d62020-06-22 11:14:20 -05003SRC_URI_witherspoon = "file://config.json"
Adriana Kobylak62348722021-03-25 16:40:34 +00004SRC_URI_p10bmc = "file://rainier-2u/config.json \
Matthew Barth530e1d82020-11-23 19:40:56 -06005 file://rainier-4u/config.json \
Andrew Geissler1053e1e2021-03-23 15:49:28 -05006 file://rainier-1s4u/config.json \
Matthew Barth530e1d82020-11-23 19:40:56 -06007 file://everest/config.json \
8 "
Matthew Barth8daae522020-06-19 13:48:27 -05009
Matthew Barth2ae06d62020-06-22 11:14:20 -050010do_install_witherspoon() {
Matthew Barth8daae522020-06-19 13:48:27 -050011 install -d ${D}/${datadir}/phosphor-fan-presence/monitor/
12 install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/
13}
14
Adriana Kobylak62348722021-03-25 16:40:34 +000015do_install_p10bmc() {
Matthew Barth530e1d82020-11-23 19:40:56 -060016 # Install Rainier-2U/4U fan monitor config files
17 install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-2u/
18 install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-4u/
Andrew Geissler1053e1e2021-03-23 15:49:28 -050019 install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-1s4u/
Matthew Barth530e1d82020-11-23 19:40:56 -060020 install -m 0644 ${WORKDIR}/rainier-2u/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-2u/
21 install -m 0644 ${WORKDIR}/rainier-4u/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-4u/
Andrew Geissler1053e1e2021-03-23 15:49:28 -050022 install -m 0644 ${WORKDIR}/rainier-1s4u/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-1s4u/
Matthew Barth530e1d82020-11-23 19:40:56 -060023
24 # Install Everest fan monitor config file
25 install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,everest/
26 install -m 0644 ${WORKDIR}/everest/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,everest/
27}
28
Matthew Barth2ae06d62020-06-22 11:14:20 -050029FILES_${PN}_append_witherspoon = " ${datadir}/phosphor-fan-presence/monitor/config.json"
30FILES_${PN}_remove_witherspoon = "${monitor_datadir}/monitor.yaml"
Matthew Barth530e1d82020-11-23 19:40:56 -060031
Adriana Kobylak62348722021-03-25 16:40:34 +000032FILES_${PN}_remove_p10bmc = "${monitor_datadir}/monitor.yaml"
33FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,rainier-2u/config.json"
34FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,rainier-4u/config.json"
35FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,rainier-1s4u/config.json"
36FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,everest/config.json"