Brad Bishop | 6e05ef2 | 2020-04-22 14:06:02 -0400 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" |
| 2 | |
Brad Bishop | 6e05ef2 | 2020-04-22 14:06:02 -0400 | [diff] [blame] | 3 | PACKAGECONFIG_append_rainier = " host-dump-offload-pldm" |
| 4 | PACKAGECONFIG_append_witherspoon-tacoma = " host-dump-offload-pldm" |
Matt Spinler | 036c8f9 | 2018-03-29 16:34:38 -0500 | [diff] [blame] | 5 | |
Dhruvaraj Subhashchandran | 0ce518f | 2020-09-24 01:33:00 -0500 | [diff] [blame] | 6 | PACKAGECONFIG_append_rainier = " openpower-dumps-extension" |
| 7 | PACKAGECONFIG_append_witherspoon-tacoma = " openpower-dumps-extension" |
| 8 | |
Matt Spinler | 036c8f9 | 2018-03-29 16:34:38 -0500 | [diff] [blame] | 9 | SRC_URI += "file://plugins.d/ibm_elogall" |
Matt Spinler | 1a247b7 | 2020-07-27 16:30:21 -0500 | [diff] [blame] | 10 | SRC_URI += "file://plugins.d/pels" |
Matt Spinler | 036c8f9 | 2018-03-29 16:34:38 -0500 | [diff] [blame] | 11 | |
| 12 | install_ibm_plugins() { |
| 13 | |
| 14 | install -m 0755 ${WORKDIR}/plugins.d/ibm_elogall ${D}${dreport_plugin_dir} |
Matt Spinler | 1a247b7 | 2020-07-27 16:30:21 -0500 | [diff] [blame] | 15 | install -m 0755 ${WORKDIR}/plugins.d/pels ${D}${dreport_plugin_dir} |
Matt Spinler | 036c8f9 | 2018-03-29 16:34:38 -0500 | [diff] [blame] | 16 | |
| 17 | } |
| 18 | |
| 19 | #Link in the plugins so dreport run them at the appropriate time |
| 20 | python link_ibm_plugins() { |
| 21 | |
| 22 | workdir = d.getVar('WORKDIR', True) |
| 23 | script = os.path.join(workdir, 'plugins.d', 'ibm_elogall') |
| 24 | install_dreport_user_script(script, d) |
Matt Spinler | 1a247b7 | 2020-07-27 16:30:21 -0500 | [diff] [blame] | 25 | |
| 26 | script = os.path.join(workdir, 'plugins.d', 'pels') |
| 27 | install_dreport_user_script(script, d) |
Matt Spinler | 036c8f9 | 2018-03-29 16:34:38 -0500 | [diff] [blame] | 28 | } |
| 29 | |
Chirag Sharma | 4971057 | 2020-09-29 08:18:17 -0500 | [diff] [blame] | 30 | #Install dump header script from dreport/ibm.d to dreport/include.d |
| 31 | install_dreport_header() { |
| 32 | install -d ${D}${dreport_include_dir} |
| 33 | install -m 0755 ${S}/tools/dreport.d/ibm.d/* ${D}${dreport_include_dir}/ |
| 34 | } |
| 35 | |
| 36 | IBM_INSTALL_POSTFUNCS = "install_ibm_plugins link_ibm_plugins" |
| 37 | IBM_INSTALL_POSTFUNCS_rainier += "install_dreport_header" |
| 38 | |
| 39 | do_install[postfuncs] += "${IBM_INSTALL_POSTFUNCS}" |