Benjamin Fair | b5087ac | 2019-09-16 11:32:43 -0700 | [diff] [blame] | 1 | SUMMARY = "Primary bootloader for NPCM7XX (Poleg) devices" |
| 2 | DESCRIPTION = "Primary bootloader for NPCM7XX (Poleg) devices" |
| 3 | HOMEPAGE = "https://github.com/Nuvoton-Israel/npcm7xx-bootblock" |
Oshri Alkoby (NTIL) | 07a65b5 | 2019-01-19 00:00:10 +0200 | [diff] [blame] | 4 | LICENSE = "CLOSED" |
| 5 | LIC_FILES_CHKSUM = "" |
| 6 | |
Benjamin Fair | b5087ac | 2019-09-16 11:32:43 -0700 | [diff] [blame] | 7 | SRCREV = "${PV}" |
Oshri Alkoby (NTIL) | 07a65b5 | 2019-01-19 00:00:10 +0200 | [diff] [blame] | 8 | FILENAME = "Poleg_bootblock.bin" |
| 9 | |
| 10 | SRC_URI = "git://github.com/Nuvoton-Israel/npcm7xx-bootblock;protocol=git" |
| 11 | SRC_URI[md5sum] = "cf8daa5f4636ed1ff952618e435af028" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit deploy |
| 16 | |
| 17 | do_deploy () { |
| 18 | install -d ${DEPLOYDIR} |
| 19 | install -m 644 ${FILENAME} ${DEPLOYDIR}/ |
| 20 | } |
| 21 | |
| 22 | addtask deploy before do_build after do_compile |