blob: 012a2631874d04b108adf1d2026f3c3369115a86 [file] [log] [blame]
Brad Bishopfd327fb2017-01-17 09:21:15 -05001SUMMARY = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
2DESCRIPTION = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
Brad Bishop07ffcce2017-01-17 09:18:39 -05003HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-oem"
4PR = "r1"
5
6inherit autotools pkgconfig
7inherit obmc-phosphor-license
Tom Josephdf686502017-02-01 19:47:27 +05308inherit obmc-phosphor-ipmiprovider-symlink
9inherit obmc-phosphor-utils
Brad Bishop07ffcce2017-01-17 09:18:39 -050010
Brad Bishop80e7f902017-01-17 10:07:14 -050011DEPENDS += "phosphor-ipmi-host"
Brad Bishop07ffcce2017-01-17 09:18:39 -050012DEPENDS += "autoconf-archive-native"
Patrick Williamscafbae62017-08-17 10:42:32 -050013DEPENDS += "sdbusplus sdbusplus-native"
14DEPENDS += "phosphor-logging"
15DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
16DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
17
18RDEPENDS_${PN} += " \
19 sdbusplus \
20 phosphor-logging \
21 openpower-dbus-interfaces \
22 phosphor-dbus-interfaces \
23 "
Brad Bishop07ffcce2017-01-17 09:18:39 -050024
25TARGET_CFLAGS += "-fpic"
26
27SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-oem"
Patrick Williams3ea29ca2017-06-16 00:40:02 -050028SRCREV = "d9296050bcece5c2eca5ede0932d944b0ced66c9"
Brad Bishop07ffcce2017-01-17 09:18:39 -050029
Tom Josephdf686502017-02-01 19:47:27 +053030HOSTIPMI_PROVIDER_LIBRARY += "liboemhandler.so"
31
Brad Bishop07ffcce2017-01-17 09:18:39 -050032S = "${WORKDIR}/git"
33
Tom Josephdf686502017-02-01 19:47:27 +053034FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Brad Bishop07ffcce2017-01-17 09:18:39 -050035FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Tom Josephdf686502017-02-01 19:47:27 +053036FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"