Brad Bishop | fd327fb | 2017-01-17 09:21:15 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor IPMI plugin for OpenPOWER OEM Commands" |
| 2 | DESCRIPTION = "Phosphor IPMI plugin for OpenPOWER OEM Commands" |
Brad Bishop | 07ffcce | 2017-01-17 09:18:39 -0500 | [diff] [blame] | 3 | HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-oem" |
| 4 | PR = "r1" |
| 5 | |
| 6 | inherit autotools pkgconfig |
| 7 | inherit obmc-phosphor-license |
Tom Joseph | df68650 | 2017-02-01 19:47:27 +0530 | [diff] [blame] | 8 | inherit obmc-phosphor-ipmiprovider-symlink |
| 9 | inherit obmc-phosphor-utils |
Brad Bishop | 07ffcce | 2017-01-17 09:18:39 -0500 | [diff] [blame] | 10 | |
Brad Bishop | 80e7f90 | 2017-01-17 10:07:14 -0500 | [diff] [blame] | 11 | DEPENDS += "phosphor-ipmi-host" |
Brad Bishop | 07ffcce | 2017-01-17 09:18:39 -0500 | [diff] [blame] | 12 | DEPENDS += "autoconf-archive-native" |
Patrick Williams | cafbae6 | 2017-08-17 10:42:32 -0500 | [diff] [blame^] | 13 | DEPENDS += "sdbusplus sdbusplus-native" |
| 14 | DEPENDS += "phosphor-logging" |
| 15 | DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native" |
| 16 | DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native" |
| 17 | |
| 18 | RDEPENDS_${PN} += " \ |
| 19 | sdbusplus \ |
| 20 | phosphor-logging \ |
| 21 | openpower-dbus-interfaces \ |
| 22 | phosphor-dbus-interfaces \ |
| 23 | " |
Brad Bishop | 07ffcce | 2017-01-17 09:18:39 -0500 | [diff] [blame] | 24 | |
| 25 | TARGET_CFLAGS += "-fpic" |
| 26 | |
| 27 | SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-oem" |
Patrick Williams | 3ea29ca | 2017-06-16 00:40:02 -0500 | [diff] [blame] | 28 | SRCREV = "d9296050bcece5c2eca5ede0932d944b0ced66c9" |
Brad Bishop | 07ffcce | 2017-01-17 09:18:39 -0500 | [diff] [blame] | 29 | |
Tom Joseph | df68650 | 2017-02-01 19:47:27 +0530 | [diff] [blame] | 30 | HOSTIPMI_PROVIDER_LIBRARY += "liboemhandler.so" |
| 31 | |
Brad Bishop | 07ffcce | 2017-01-17 09:18:39 -0500 | [diff] [blame] | 32 | S = "${WORKDIR}/git" |
| 33 | |
Tom Joseph | df68650 | 2017-02-01 19:47:27 +0530 | [diff] [blame] | 34 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
Brad Bishop | 07ffcce | 2017-01-17 09:18:39 -0500 | [diff] [blame] | 35 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
Tom Joseph | df68650 | 2017-02-01 19:47:27 +0530 | [diff] [blame] | 36 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |