Brad Bishop | 0a81db0 | 2016-08-30 00:46:40 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor DBUS to REST WSGI Application" |
| 2 | DESCRIPTION = "Phosphor DBUS to REST WSGI Application." |
Brad Bishop | 5da8564 | 2015-10-27 17:13:26 -0400 | [diff] [blame] | 3 | PR = "r1" |
Patrick Venture | dc10ea7 | 2018-10-03 13:18:43 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Brad Bishop | 5da8564 | 2015-10-27 17:13:26 -0400 | [diff] [blame] | 5 | |
| 6 | inherit allarch |
| 7 | inherit obmc-phosphor-systemd |
| 8 | inherit setuptools |
Ratan Gupta | 653779c | 2016-10-01 14:57:15 -0500 | [diff] [blame] | 9 | inherit obmc-phosphor-discovery-service |
Brad Bishop | 5da8564 | 2015-10-27 17:13:26 -0400 | [diff] [blame] | 10 | |
Patrick Williams | 969c16d | 2017-03-01 21:25:36 -0600 | [diff] [blame] | 11 | require phosphor-rest.inc |
| 12 | |
Dhruvaraj Subhashchandran | 9737db8 | 2017-10-12 04:43:17 -0500 | [diff] [blame] | 13 | RRECOMMENDS_${PN} += " \ |
| 14 | virtual-obmc-wsgihost \ |
| 15 | python-gevent-websocket \ |
| 16 | " |
Brad Bishop | 0a81db0 | 2016-08-30 00:46:40 -0400 | [diff] [blame] | 17 | |
Brad Bishop | 5da8564 | 2015-10-27 17:13:26 -0400 | [diff] [blame] | 18 | RDEPENDS_${PN} += " \ |
| 19 | python-xml \ |
| 20 | python-dbus \ |
Brad Bishop | 1122eb0 | 2016-10-05 20:10:23 -0400 | [diff] [blame] | 21 | phosphor-mapper \ |
Brad Bishop | f668817 | 2016-04-15 09:41:54 -0400 | [diff] [blame] | 22 | python-bottle \ |
| 23 | python-spwd \ |
Brad Bishop | 1b4e447 | 2016-08-29 21:47:04 -0400 | [diff] [blame] | 24 | pyphosphor-utils \ |
| 25 | pyphosphor-dbus \ |
Brad Bishop | 0a81db0 | 2016-08-30 00:46:40 -0400 | [diff] [blame] | 26 | pyphosphor-wsgi-apps-ns \ |
Tom Joseph | 65c5362 | 2018-09-03 22:08:21 -0500 | [diff] [blame] | 27 | pamela \ |
Adriana Kobylak | 59e96d7 | 2018-09-24 14:27:15 -0500 | [diff] [blame] | 28 | jsnbd \ |
Brad Bishop | 5da8564 | 2015-10-27 17:13:26 -0400 | [diff] [blame] | 29 | " |
Nagaraju Goruganti | 8753f64 | 2018-06-01 00:19:42 -0500 | [diff] [blame] | 30 | SRC_URI += "file://url_config.json \ |
| 31 | " |
| 32 | |
| 33 | FILES_${PN}_append = " ${datadir}/rest-dbus/url_config.json" |
Brad Bishop | 5da8564 | 2015-10-27 17:13:26 -0400 | [diff] [blame] | 34 | |
Brad Bishop | 0a81db0 | 2016-08-30 00:46:40 -0400 | [diff] [blame] | 35 | S = "${WORKDIR}/git/module" |
| 36 | SYSTEMD_SERVICE_${PN} = "" |
| 37 | SYSTEMD_OVERRIDE_${PN} += "rest-dbus.conf:obmc-mapper.target.d/rest-dbus.conf" |
| 38 | SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/wsgi_app" |
Ratan Gupta | 653779c | 2016-10-01 14:57:15 -0500 | [diff] [blame] | 39 | REGISTERED_SERVICES_${PN} += "phosphor_rest:tcp:443" |
Nagaraju Goruganti | 8753f64 | 2018-06-01 00:19:42 -0500 | [diff] [blame] | 40 | |
| 41 | do_install_append(){ |
| 42 | install -d ${D}${datadir}/rest-dbus |
| 43 | install -m 0644 -D ${WORKDIR}/url_config.json \ |
| 44 | ${D}${datadir}/rest-dbus/url_config.json |
| 45 | } |