blob: 0c8687c92567ffcc54cd198007f1b4632b0c9e29 [file] [log] [blame]
Adriana Kobylakfa7c2122015-10-19 14:15:04 -04001SUMMARY = "Temp placeholder for skeleton function"
2DESCRIPTION = "Temp placeholder for skeleton repository"
3HOMEPAGE = "http://github.com/openbmc/skeleton"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
Brad Bishop5a4b9532015-10-21 20:24:23 -04008inherit obmc-phosphor-chassis-mgmt
9inherit obmc-phosphor-event-mgmt
10inherit obmc-phosphor-fan-mgmt
11inherit obmc-phosphor-flash-mgmt
12inherit obmc-phosphor-policy-mgmt
13inherit obmc-phosphor-sensor-mgmt
14inherit obmc-phosphor-system-mgmt
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040015
16DEPENDS += "glib-2.0"
Brad Bishopd1e4e3f2015-10-19 14:22:57 -040017RDEPENDS_${PN} += "python-subprocess python-tftpy"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040018SRC_URI += "git://github.com/openbmc/skeleton"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040019
Norman Jamesb3422792015-10-20 16:28:16 -050020SRCREV = "47750bc1c06aebda189f2e8d7862c9d9b9ffe35b"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040021
Brad Bishopb264b812015-10-28 08:13:43 -050022S = "${WORKDIR}"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040023
24do_compile() {
Brad Bishopb264b812015-10-28 08:13:43 -050025 oe_runmake -C git all
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040026}
27
28do_install() {
Brad Bishopb264b812015-10-28 08:13:43 -050029 source=${S}/git
30
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040031 install -d ${D}/${sbindir} ${D}${libdir}
Brad Bishopb264b812015-10-28 08:13:43 -050032 for i in ${source}/bin/*.py ${source}/bin/*.exe; do
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040033 install $i ${D}/${sbindir}
34 done
Brad Bishopb264b812015-10-28 08:13:43 -050035 install ${source}/bin/libopenbmc_intf.so ${D}/${libdir}
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040036}