blob: a440003514240b4aeb158d650160ceba17e0abc1 [file] [log] [blame]
Brad Bishop595edcf2016-11-09 20:43:11 -05001SUMMARY = "C++ bindings for systemd dbus APIs"
2DESCRIPTION = "C++ bindings for systemd dbus APIs."
Brad Bishop595edcf2016-11-09 20:43:11 -05003
4inherit autotools pkgconfig
Patrick Williams58185302016-11-22 07:01:14 -06005inherit obmc-phosphor-python-autotools
Brad Bishop595edcf2016-11-09 20:43:11 -05006
Patrick Williams25448842020-03-31 12:51:05 -05007include sdbusplus-rev.inc
8
Nagaraju Goruganti78077a52017-08-22 05:24:26 -05009DEPENDS += " \
10 autoconf-archive-native \
Patrick Williams4cd22432020-02-24 16:27:10 -060011 ${PYTHON_PN}-inflection-native \
12 ${PYTHON_PN}-mako-native \
13 ${PYTHON_PN}-pyyaml-native \
Nagaraju Goruganti78077a52017-08-22 05:24:26 -050014 "
Brad Bishop29dc8702017-01-12 14:06:43 -050015RDEPENDS_sdbus++ += " \
Patrick Williams4cd22432020-02-24 16:27:10 -060016 ${PYTHON_PN} \
17 ${PYTHON_PN}-inflection \
18 ${PYTHON_PN}-mako \
19 ${PYTHON_PN}-pyyaml \
Brad Bishop595edcf2016-11-09 20:43:11 -050020 "
21
Brad Bishop32f0a9a2017-01-18 13:59:33 -050022# sdbus++ has a handful of runtime dependencies on other python packages.
23# Bitbake doesn't do anything with RDEPENDS in native context because
24# native context doesn't have packages.
25#
26# While technically sdbus++ doesn't require its runtime dependencies to be
27# installed to build, work around the above native context behavior
28# by adding a build dependency so that clients don't have to DEPEND
29# on sdbus++ runtime dependencies manually.
30
31DEPENDS_append_class-native = " \
Patrick Williams4cd22432020-02-24 16:27:10 -060032 ${PYTHON_PN}-inflection-native \
33 ${PYTHON_PN}-mako-native \
34 ${PYTHON_PN}-pyyaml-native \
Brad Bishop32f0a9a2017-01-18 13:59:33 -050035 "
36
Adriana Kobylak178d6b52017-02-12 17:40:26 -060037PACKAGECONFIG ??= "libsdbusplus transaction"
Brad Bishop595edcf2016-11-09 20:43:11 -050038PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
Adriana Kobylak178d6b52017-02-12 17:40:26 -060039PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction"
Brad Bishop595edcf2016-11-09 20:43:11 -050040
Patrick Williams29792022016-11-22 11:05:11 -060041PROVIDES_prepend = "sdbus++ "
Brad Bishopcc01d1a2018-02-27 00:30:06 -050042PACKAGE_BEFORE_PN = "sdbus++"
Patrick Williams29792022016-11-22 11:05:11 -060043FILES_sdbus++_append = " ${bindir}/sdbus++"
44PYTHON_AUTOTOOLS_PACKAGE = "sdbus++"
45
Brad Bishop595edcf2016-11-09 20:43:11 -050046PACKAGECONFIG_remove_class-native = "libsdbusplus"
47PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus"
48
Brad Bishop595edcf2016-11-09 20:43:11 -050049BBCLASSEXTEND += "native nativesdk"