blob: 83f5936358a79ec5a21b8331be1eb2de086fee3e [file] [log] [blame]
Patrick Venture028d2402018-03-09 15:37:45 -08001SUMMARY = "Phosphor PID Fan Control"
2DESCRIPTION = "Fan Control"
Patrick Venturec311dec2018-09-29 09:19:22 -07003HOMEPAGE = "github.com/openbmc/phosphor-pid-control"
Patrick Venture028d2402018-03-09 15:37:45 -08004PR = "r1"
Patrick Venturec311dec2018-09-29 09:19:22 -07005PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture028d2402018-03-09 15:37:45 -08008
James Feistae3f0852018-11-20 11:29:16 -08009inherit flto-automake pkgconfig
Patrick Venture028d2402018-03-09 15:37:45 -080010
11inherit phosphor-pid-control
12inherit obmc-phosphor-ipmiprovider-symlink
13
Patrick Venturec311dec2018-09-29 09:19:22 -070014S = "${WORKDIR}/git"
15SRC_URI = "git://github.com/openbmc/phosphor-pid-control"
Andrew Geisslerfcff32b2019-03-26 16:02:06 +000016SRCREV = "e3eeef45a722b57d4c3bb379df165e0bd14993bd"
Patrick Venturec311dec2018-09-29 09:19:22 -070017
Patrick Venture028d2402018-03-09 15:37:45 -080018# Each platform will need a service file that starts
19# at an appropriate time per system. For instance, if
20# your system relies on passive dbus for fans or other
21# sensors then it may be prudent to wait for all of them.
22
23DEPENDS += "autoconf-archive-native"
Patrick Venture028d2402018-03-09 15:37:45 -080024DEPENDS += "sdbusplus"
Brad Bishop26873c92019-03-22 23:41:42 -040025DEPENDS += "phosphor-dbus-interfaces"
Patrick Venture028d2402018-03-09 15:37:45 -080026DEPENDS += "phosphor-logging"
Patrick Venture135828d2019-03-26 10:42:53 -070027DEPENDS += "phosphor-dbus-interfaces"
Patrick Venture028d2402018-03-09 15:37:45 -080028DEPENDS += "libevdev"
Patrick Venture9b40f492019-02-12 08:59:31 -080029DEPENDS += "nlohmann-json"
Patrick Ventured0742562019-03-11 08:45:12 -070030DEPENDS += "cli11"
Patrick Venture028d2402018-03-09 15:37:45 -080031
Patrick Venture028d2402018-03-09 15:37:45 -080032# We depend on this to be built first so we can build our providers.
33DEPENDS += "phosphor-ipmi-host"
34
Patrick Venture028d2402018-03-09 15:37:45 -080035FILES_${PN} = "${sbindir}/swampd ${sbindir}/setsensor"
36
Patrick Venture13a1e6b2018-07-27 07:27:01 -070037# The following installs the OEM IPMI handler for the fan controls.
38FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
39FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
40FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
41FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Patrick Venture028d2402018-03-09 15:37:45 -080042
Patrick Venture13a1e6b2018-07-27 07:27:01 -070043HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so"