blob: 3bf7ca7d84d7c60a26c14ba2ca3b79da6ef6d55d [file] [log] [blame]
Patrick Venture2ff2ecc2018-11-09 18:27:28 -08001HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash"
2SUMMARY = "Phosphor OEM IPMI In-band Firmware Update over BLOB"
3DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the firmware update handler over the BLOB protocol."
4PR = "r1"
Patrick Venturee4e8e7b2019-06-28 15:34:15 -07005PV = "1.0+git${SRCPV}"
Patrick Venture2ff2ecc2018-11-09 18:27:28 -08006LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
Andrew Geisslera560e8e2019-07-08 19:51:12 +000011inherit systemd
Patrick Venture2ff2ecc2018-11-09 18:27:28 -080012
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "phosphor-ipmi-blobs"
15DEPENDS += "phosphor-logging"
16DEPENDS += "sdbusplus"
Andrew Geisslera560e8e2019-07-08 19:51:12 +000017DEPENDS += "systemd"
Patrick Venturef0bb2a92019-03-07 10:51:53 -080018DEPENDS += "ipmi-blob-tool"
Patrick Venturecb35b592019-05-03 10:35:28 -070019DEPENDS += "pciutils"
Patrick Venture2ff2ecc2018-11-09 18:27:28 -080020
Andrew Geissler67a224f2019-06-19 18:52:19 +000021PACKAGECONFIG ?= "cleanup-delete"
22PACKAGECONFIG[cleanup-delete] = "--enable-cleanup-delete, --disable-cleanup-delete"
Patrick Venture1e8155c2019-06-28 19:28:28 -070023# If using static-layout, reboot-update is a good option to handle updating.
24PACKAGECONFIG[reboot-update] = "--enable-reboot-update, --disable-reboot-update"
Andrew Geisslera560e8e2019-07-08 19:51:12 +000025PACKAGECONFIG[host-bios] = "--enable-host-bios, --disable-host-bios"
Andrew Geissler67a224f2019-06-19 18:52:19 +000026
Patrick Venture7f113ef2019-07-15 09:39:43 -070027# Hardware options to enable transmitting the data from the host.
28PACKAGECONFIG[aspeed-p2a] = "--enable-aspeed-p2a, --disable-aspeed-p2a"
29PACKAGECONFIG[aspeed-lpc] = "--enable-aspeed-lpc, --disable-aspeed-lpc"
30PACKAGECONFIG[nuvoton-lpc] = "--enable-nuvoton-lpc, --disable-nuvoton-lpc"
31
Patrick Venturef65a4e22019-05-15 12:19:16 -070032EXTRA_OECONF = "--disable-tests --disable-build-host-tool"
33
Patrick Venture2fba5de2019-07-15 09:50:03 -070034# Set this variable in your recipe to set it instead of using MAPPED_ADDRESS directly.
35IPMI_FLASH_BMC_ADDRESS ?= "0"
36EXTRA_OECONF_append = " MAPPED_ADDRESS=${IPMI_FLASH_BMC_ADDRESS}"
37
Patrick Venture2ff2ecc2018-11-09 18:27:28 -080038S = "${WORKDIR}/git"
39SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash"
Andrew Geisslerd61d6c12019-07-18 22:31:19 +000040SRCREV = "298930a18d01b4685aab3a7018299c7342afa028"
Andrew Geisslera560e8e2019-07-08 19:51:12 +000041
42SYSTEMD_PACKAGES = "${PN}"
43SYSTEMD_SERVICE_${PN} += "phosphor-ipmi-flash-bmc-prepare.target \
44 phosphor-ipmi-flash-bmc-verify.target \
45 phosphor-ipmi-flash-bmc-update.target"
46
47# If they enabled host-bios, add those three extra targets.
48HOST_BIOS_TARGETS = "phosphor-ipmi-flash-bios-prepare.target \
49 phosphor-ipmi-flash-bios-verify.target \
50 phosphor-ipmi-flash-bios-update.target"
51
52SYSTEMD_SERVICE_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'host-bios', '${HOST_BIOS_TARGETS}', '', d)}"
Patrick Venture2ff2ecc2018-11-09 18:27:28 -080053
54FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
55FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
56FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
57
58BLOBIPMI_PROVIDER_LIBRARY += "libfirmwareblob.so"
Andrew Geissler67a224f2019-06-19 18:52:19 +000059BLOBIPMI_PROVIDER_LIBRARY += "${@bb.utils.contains('PACKAGECONFIG', 'cleanup-delete', 'libfirmwarecleanupblob.so', '', d)}"
Patrick Venturee21be192019-05-08 07:43:10 -070060
61do_configure[depends] += "virtual/kernel:do_shared_workdir"