Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 1 | SUMMARY = "Phosphor PID Fan Control" |
| 2 | DESCRIPTION = "Fan Control" |
Patrick Venture | c311dec | 2018-09-29 09:19:22 -0700 | [diff] [blame] | 3 | HOMEPAGE = "github.com/openbmc/phosphor-pid-control" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 4 | PR = "r1" |
Patrick Venture | c311dec | 2018-09-29 09:19:22 -0700 | [diff] [blame] | 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 8 | |
James Feist | ae3f085 | 2018-11-20 11:29:16 -0800 | [diff] [blame] | 9 | inherit flto-automake pkgconfig |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 10 | inherit pythonnative |
| 11 | |
| 12 | inherit phosphor-pid-control |
| 13 | inherit obmc-phosphor-ipmiprovider-symlink |
| 14 | |
Patrick Venture | c311dec | 2018-09-29 09:19:22 -0700 | [diff] [blame] | 15 | S = "${WORKDIR}/git" |
| 16 | SRC_URI = "git://github.com/openbmc/phosphor-pid-control" |
Andrew Geissler | 6e897aa | 2019-03-13 00:01:57 +0000 | [diff] [blame] | 17 | SRCREV = "b5cc37cebec74f0bd2a8d378d5f911fc4fa3439e" |
Patrick Venture | c311dec | 2018-09-29 09:19:22 -0700 | [diff] [blame] | 18 | |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 19 | # Each platform will need a service file that starts |
| 20 | # at an appropriate time per system. For instance, if |
| 21 | # your system relies on passive dbus for fans or other |
| 22 | # sensors then it may be prudent to wait for all of them. |
| 23 | |
| 24 | DEPENDS += "autoconf-archive-native" |
| 25 | DEPENDS += "python-pyyaml-native" |
| 26 | DEPENDS += "python-mako-native" |
| 27 | DEPENDS += "sdbusplus" |
| 28 | DEPENDS += "phosphor-logging" |
| 29 | DEPENDS += "libevdev" |
Patrick Venture | 9b40f49 | 2019-02-12 08:59:31 -0800 | [diff] [blame] | 30 | DEPENDS += "nlohmann-json" |
Patrick Venture | d074256 | 2019-03-11 08:45:12 -0700 | [diff] [blame] | 31 | DEPENDS += "cli11" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 32 | |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 33 | # We depend on this to be built first so we can build our providers. |
| 34 | DEPENDS += "phosphor-ipmi-host" |
| 35 | |
| 36 | RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces" |
| 37 | |
| 38 | FILES_${PN} = "${sbindir}/swampd ${sbindir}/setsensor" |
| 39 | |
Patrick Venture | 13a1e6b | 2018-07-27 07:27:01 -0700 | [diff] [blame] | 40 | # The following installs the OEM IPMI handler for the fan controls. |
| 41 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 42 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 43 | FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 44 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 45 | |
Patrick Venture | 13a1e6b | 2018-07-27 07:27:01 -0700 | [diff] [blame] | 46 | HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so" |