blob: e85b2609c42dcb8f711412df83330d88bea8ae8f [file] [log] [blame]
vishwabmc1bf499d2015-10-09 15:51:50 +05301SUMMARY = "Phosphor OpenBMC IPMI daemon"
2DESCRIPTION = "Phosphor OpenBMC IPMI router and plugin libraries"
vishwabmc1bf499d2015-10-09 15:51:50 +05303PR = "r1"
Patrick Venturef30b8842018-10-21 08:27:22 -07004PV = "1.0+git${SRCPV}"
Patrick Venture64329372018-11-03 09:42:59 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
vishwabmc1bf499d2015-10-09 15:51:50 +05307
Brad Bishop7ee71462016-08-19 09:02:54 -05008RRECOMMENDS_${PN} += "packagegroup-obmc-ipmid-providers-libs"
Chris Austen213cd2a2015-10-24 19:34:11 -05009
Matthew Barth302592f2016-08-16 16:51:35 -050010inherit autotools pkgconfig
Patrick Ventured3dd0942017-12-22 14:36:07 -080011inherit obmc-phosphor-ipmiprovider-symlink
Patrick Williamsf7714062015-10-15 15:20:20 -050012inherit obmc-phosphor-sdbus-service
Patrick Ventured3dd0942017-12-22 14:36:07 -080013inherit obmc-phosphor-systemd
Ratan Guptab92d0ec2017-03-06 17:05:11 +053014inherit phosphor-ipmi-host
15inherit pythonnative
vishwabmc1bf499d2015-10-09 15:51:50 +053016
Brad Bishop7f2ade02018-01-26 22:11:36 -050017def ipmi_whitelists(d):
18 whitelists = d.getVar(
19 'VIRTUAL-RUNTIME_phosphor-ipmi-providers', True) or ''
20 whitelists = whitelists.split()
21 whitelists = [ '{}-whitelist-native'.format(x) for x in whitelists ]
22 return ' '.join(whitelists)
23
Patrick Ventured3dd0942017-12-22 14:36:07 -080024DEPENDS += "autoconf-archive-native"
David Cobbley1dc78fb2017-11-21 16:17:40 -080025DEPENDS += "nlohmann-json"
Patrick Ventured3dd0942017-12-22 14:36:07 -080026DEPENDS += "obmc-targets"
Brad Bishop7f2ade02018-01-26 22:11:36 -050027DEPENDS += "${@ipmi_whitelists(d)}"
Patrick Ventured3dd0942017-12-22 14:36:07 -080028DEPENDS += "phosphor-dbus-interfaces"
Adriana Kobylak17885c22017-02-17 08:21:42 -060029DEPENDS += "phosphor-logging"
Brad Bishop1122eb02016-10-05 20:10:23 -040030DEPENDS += "phosphor-mapper"
Ratan Gupta8dc22a92017-03-20 18:20:47 +053031DEPENDS += "sdbusplus"
Patrick Ventured3dd0942017-12-22 14:36:07 -080032DEPENDS += "sdbus++-native"
Tom Josephf2614f92017-05-08 11:49:10 +053033DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
Marri Devender Rao5a0088c2017-07-26 02:11:32 -050034DEPENDS += "virtual/phosphor-ipmi-fru-merge-config"
Patrick Ventured3dd0942017-12-22 14:36:07 -080035DEPENDS += "virtual/phosphor-ipmi-sensor-inventory"
Patrick Ventureafdf9842018-01-18 18:01:29 -080036DEPENDS += "virtual/phosphor-ipmi-channel-config"
Andrew Geisslera561ec92018-09-25 19:50:20 +000037DEPENDS += "boost"
Patrick Venture12a94a82018-11-07 17:48:53 -080038DEPENDS += "sdeventplus"
Ratan Guptab92d0ec2017-03-06 17:05:11 +053039
Andrew Jeffery381e1e92018-04-06 14:13:14 +093040VIRTUAL-RUNTIME_ipmi-config ?= "phosphor-ipmi-config"
41
Adriana Kobylak17885c22017-02-17 08:21:42 -060042RDEPENDS_${PN}-dev += "phosphor-logging"
Brad Bishop1122eb02016-10-05 20:10:23 -040043RDEPENDS_${PN}-dev += "phosphor-mapper-dev"
Milton D. Miller II611e3ff2016-03-04 15:29:29 -060044RDEPENDS_${PN} += "clear-once"
Brad Bishop9a701b42016-07-26 15:52:01 -040045RDEPENDS_${PN} += "libmapper"
Patrick Ventured3dd0942017-12-22 14:36:07 -080046RDEPENDS_${PN} += "network"
47RDEPENDS_${PN} += "phosphor-dbus-interfaces"
48RDEPENDS_${PN} += "phosphor-mapper"
Vishwanatha Subbanna78bc5422016-11-10 21:52:46 +053049RDEPENDS_${PN} += "phosphor-time-manager"
Patrick Ventured3dd0942017-12-22 14:36:07 -080050RDEPENDS_${PN} += "sdbusplus"
Andrew Jeffery381e1e92018-04-06 14:13:14 +093051RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_ipmi-config}"
Vishwanatha Subbanna55c545a2017-06-12 13:09:10 +053052RDEPENDS_${PN} += "virtual/obmc-watchdog"
Ratan Gupta8dc22a92017-03-20 18:20:47 +053053
Richard Marian Thomaiyarfe5b8d22018-08-20 20:14:16 +053054inherit useradd
55
56USERADD_PACKAGES = "${PN}"
57# add ipmi group
58GROUPADD_PARAM_${PN} = "ipmi"
Richard Marian Thomaiyar41882fb2018-12-14 09:04:40 +053059# Add root user to ipmi group
60GROUPMEMS_PARAM_${PN} = "-g ipmi -a root"
Richard Marian Thomaiyarfe5b8d22018-08-20 20:14:16 +053061
Vishwanatha Subbanna35318402017-03-31 14:41:11 +053062SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service phosphor-ipmi-host.service"
63
Andrew Geissler78e04542018-02-05 12:02:35 -080064RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_obmc-settings-mgmt}"
65
vishwabmc1bf499d2015-10-09 15:51:50 +053066
Marri Devender Rao52a9f2d2017-06-08 00:47:54 -050067require ${PN}.inc
Chris Austen213cd2a2015-10-24 19:34:11 -050068
Tom Josephf07ae012017-02-20 12:01:43 +053069# Setup IPMI Whitelist Conf files
70WHITELIST_CONF = " \
Patrick Williamsf11f0152017-02-24 13:04:06 -060071 ${STAGING_DATADIR_NATIVE}/phosphor-ipmi-host/*.conf \
Tom Josephf07ae012017-02-20 12:01:43 +053072 ${S}/host-ipmid-whitelist.conf \
73 "
74EXTRA_OECONF = " \
75 WHITELIST_CONF="${WHITELIST_CONF}" \
Ratan Guptab92d0ec2017-03-06 17:05:11 +053076 SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor.yaml \
Tom Josephf2614f92017-05-08 11:49:10 +053077 INVSENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/invsensor.yaml \
Marri Devender Rao5a0088c2017-07-26 02:11:32 -050078 FRU_YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/fru_config.yaml \
Patrick Ventureafdf9842018-01-18 18:01:29 -080079 CHANNEL_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/channel.yaml \
Marri Devender Rao9f32d172018-01-18 11:21:19 -060080 POWER_READING_SENSOR=${datadir}/ipmi-providers/power_reading.json\
Tom Josephf07ae012017-02-20 12:01:43 +053081 "
82
vishwabmc1bf499d2015-10-09 15:51:50 +053083S = "${WORKDIR}/git"
84
Andrew Jeffery381e1e92018-04-06 14:13:14 +093085SRC_URI += "file://merge_yamls.py "
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -050086
Vernon Mauery595c7382018-07-30 15:49:09 -070087HOSTIPMI_PROVIDER_LIBRARY += "libipmi20.so"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053088HOSTIPMI_PROVIDER_LIBRARY += "libsysintfcmds.so"
89
Vernon Mauery595c7382018-07-30 15:49:09 -070090NETIPMI_PROVIDER_LIBRARY += "libipmi20.so"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053091
Matthew Barth302592f2016-08-16 16:51:35 -050092FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Patrick Ventured3dd0942017-12-22 14:36:07 -080093FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053094FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
95FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Brad Bishop3b524cf2016-09-06 13:03:39 -040096
Andrew Geisslerafc510f2017-01-04 11:11:50 -060097# Soft Power Off
Andrew Geisslerd40db752017-05-11 16:16:27 -050098# install the soft power off service in the host shutdown target
99SOFT_SVC = "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service"
100SOFT_TGTFMT = "obmc-host-shutdown@{0}.target"
101SOFT_FMT = "../${SOFT_SVC}:${SOFT_TGTFMT}.requires/${SOFT_SVC}"
102SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'SOFT_FMT', 'OBMC_HOST_INSTANCES')}"
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500103
104#Collect all hardcoded sensor yamls from different recipes and
105#merge all of them with sensor.yaml.
106python do_merge_sensors () {
107 import subprocess
108
109 # TODO: Perform the merge in a temporary directory?
110 workdir = d.getVar('WORKDIR', True)
111 nativedir = d.getVar('STAGING_DIR_NATIVE', True)
112 sensorsdir = d.getVar('sensor_datadir', True)
113 sensorsdir = sensorsdir[1:]
114 sensorsdir = os.path.join(nativedir, sensorsdir)
115 cmd = []
116 cmd.append(os.path.join(workdir, 'merge_yamls.py'))
117 cmd.append(os.path.join(sensorsdir, 'sensor.yaml'))
118
119 if os.stat(os.path.join(sensorsdir, 'sensor.yaml')).st_size == 0:
120 return
121 fetch = bb.fetch2.Fetch([], d)
Kun Yie6bd58c2017-10-09 23:17:08 -0700122 override_urls = [url for url in fetch.urls if url.endswith('.hardcoded.yaml')]
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500123 for url in override_urls:
124 bb.debug(2, 'Overriding with source: ' + url)
125 local_base = os.path.basename(fetch.localpath(url))
126 filename = os.path.join(workdir, local_base)
127 cmd.append(filename)
128
129 # Invoke the script and don't catch any resulting exception.
130 subprocess.check_call(cmd)
131}
Andrew Jeffery381e1e92018-04-06 14:13:14 +0930132
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500133# python-pyyaml-native is installed by do_configure, so put this task after
134addtask merge_sensors after do_configure before do_compile