blob: becb6f89bfc677d3001f69bac6b8af47fecf50d9 [file] [log] [blame]
Brad Bishopb0c3b272017-01-11 11:12:32 -05001SUMMARY = "OpenBMC hwmon poller"
2DESCRIPTION = "OpenBMC hwmon poller."
3PR = "r1"
Patrick Venture8f1d06b2018-10-01 20:22:40 -07004PV = "1.0+git${SRCPV}"
Brad Bishopb0c3b272017-01-11 11:12:32 -05005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Patrick Venture8f1d06b2018-10-01 20:22:40 -07008inherit autotools pkgconfig
9inherit obmc-phosphor-systemd
Brad Bishop030da252017-01-11 15:30:07 -050010
Brad Bishop1d34ddd2017-08-01 21:33:30 -040011PACKAGE_BEFORE_PN = "max31785-msl"
12SYSTEMD_PACKAGES = "${PN} max31785-msl"
13
Brad Bishop030da252017-01-11 15:30:07 -050014SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Hwmon@.service"
Brad Bishop1d34ddd2017-08-01 21:33:30 -040015SYSTEMD_SERVICE_max31785-msl = "phosphor-max31785-msl@.service"
Brad Bishopb0c3b272017-01-11 11:12:32 -050016
17DEPENDS += "autoconf-archive-native"
Brad Bishopf4393bf2017-02-20 14:36:31 -050018DEPENDS += " \
19 sdbusplus \
20 phosphor-dbus-interfaces \
21 phosphor-logging \
Patrick Venture03c53912018-09-14 09:54:18 -070022 gpioplus \
Brad Bishopf4393bf2017-02-20 14:36:31 -050023 "
24
Brad Bishopb0c3b272017-01-11 11:12:32 -050025
26RDEPENDS_${PN} += "\
Brad Bishopf4393bf2017-02-20 14:36:31 -050027 sdbusplus \
28 phosphor-dbus-interfaces \
29 phosphor-logging \
Patrick Venture03c53912018-09-14 09:54:18 -070030 gpioplus \
Joel Stanley7b29e202017-09-05 17:44:33 +100031 bash \
Brad Bishopb0c3b272017-01-11 11:12:32 -050032 "
33
Brad Bishopfe7871c2017-02-22 20:50:13 -050034RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_phosphor-hwmon-config}"
35
Brad Bishop1d34ddd2017-08-01 21:33:30 -040036FILES_max31785-msl = "${bindir}/max31785-msl"
37RDEPENDS_max31785-msl = "${VIRTUAL-RUNTIME_base-utils} i2c-tools"
38
Brad Bishopb0c3b272017-01-11 11:12:32 -050039SRC_URI += "git://github.com/openbmc/phosphor-hwmon"
Brad Bishop030da252017-01-11 15:30:07 -050040SRC_URI += "file://70-hwmon.rules"
Brandon Wyman675ce0b2017-06-21 16:32:56 -050041SRC_URI += "file://70-iio.rules"
Joel Stanley7b29e202017-09-05 17:44:33 +100042SRC_URI += "file://start_hwmon.sh"
Brad Bishopb0c3b272017-01-11 11:12:32 -050043
Andrew Geissler425b2cd2018-10-13 21:10:26 +000044SRCREV = "685efa165adc20d480e4c4994d62d62cd1e2f2d6"
Brad Bishopb0c3b272017-01-11 11:12:32 -050045
46S = "${WORKDIR}/git"
Brad Bishop030da252017-01-11 15:30:07 -050047
48do_install_append() {
49
Brad Bishopf5812fd2017-01-26 09:12:57 -050050 install -d ${D}/${base_libdir}/udev/rules.d/
51 install ${WORKDIR}/70-hwmon.rules ${D}/${base_libdir}/udev/rules.d/
Brandon Wyman675ce0b2017-06-21 16:32:56 -050052 install ${WORKDIR}/70-iio.rules ${D}/${base_libdir}/udev/rules.d/
Joel Stanley7b29e202017-09-05 17:44:33 +100053
54 install -d ${D}${bindir}
55 install -m 0755 ${WORKDIR}/start_hwmon.sh ${D}${bindir}
Brad Bishop030da252017-01-11 15:30:07 -050056}