blob: c97e6bba3006bf1c9573c94bdda391ade430cbc4 [file] [log] [blame]
Brad Bishopff7bf4b2017-01-17 09:14:15 -05001SUMMARY = "Phosphor IPMI Inventory Plugin"
2DESCRIPTION = "A Phosphor IPMI plugin that updates inventory."
Chris Austenf7cefb12015-11-01 22:27:34 -06003PR = "r1"
Patrick Venture6f1857e2018-10-01 20:56:22 -07004PV = "1.0+git${SRCPV}"
Chris Austenf7cefb12015-11-01 22:27:34 -06005
Matthew Barth2c455f02016-10-19 16:00:49 -05006inherit autotools pkgconfig
Brad Bishop0fe80462016-08-17 20:27:37 -04007inherit obmc-phosphor-systemd
Tom Joseph40b4e3f2017-02-01 19:47:27 +05308inherit obmc-phosphor-ipmiprovider-symlink
Brad Bishop2c5db6a2017-01-28 13:00:52 -05009inherit phosphor-ipmi-fru
10inherit pythonnative
Chris Austenf7cefb12015-11-01 22:27:34 -060011
Brad Bishopee064612017-01-17 10:10:02 -050012require ${PN}.inc
13
Brad Bishopdd2e4fa2016-06-13 12:53:41 -040014DEPENDS += " \
Brad Bishop2c5db6a2017-01-28 13:00:52 -050015 virtual/phosphor-ipmi-fru-hostfw-config\
16 virtual/phosphor-ipmi-fru-inventory \
Deepak Kodihalli5b183e02017-02-20 04:55:20 -060017 virtual/phosphor-ipmi-fru-properties \
Brad Bishopdd2e4fa2016-06-13 12:53:41 -040018 systemd \
Deepak Kodihalli5df911b2017-02-16 07:50:37 -060019 sdbusplus \
Brad Bishop2c5db6a2017-01-28 13:00:52 -050020 python-mako-native \
21 python-pyyaml-native \
Brad Bishopc30d7bb2017-01-17 10:07:14 -050022 phosphor-ipmi-host \
Matthew Barth2c455f02016-10-19 16:00:49 -050023 phosphor-mapper \
24 autoconf-archive-native \
Brad Bishopdd2e4fa2016-06-13 12:53:41 -040025 "
Chris Austenf7cefb12015-11-01 22:27:34 -060026
Deepak Kodihalli5df911b2017-02-16 07:50:37 -060027RDEPENDS_${PN} += " \
28 sdbusplus \
29 "
Chris Austenf7cefb12015-11-01 22:27:34 -060030
Brad Bishop0fe80462016-08-17 20:27:37 -040031SYSTEMD_SERVICE_${PN} += "obmc-read-eeprom@.service"
Chris Austenf7cefb12015-11-01 22:27:34 -060032
Chris Austenf7cefb12015-11-01 22:27:34 -060033S = "${WORKDIR}/git"
34
Tom Joseph40b4e3f2017-02-01 19:47:27 +053035HOSTIPMI_PROVIDER_LIBRARY += "libstrgfnhandler.so"
36
37FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Matthew Barth2c455f02016-10-19 16:00:49 -050038FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053039FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Brad Bishop2c5db6a2017-01-28 13:00:52 -050040
41# TODO: Fix the the ipmi-fru-parser code generator to handle split
42# host firmware / inventory YAML and replace the OECONF below with:
43#
44# EXTRA_OECONF += "INVENTORY_YAML=${inventory_datadir}/config.yaml"
45# EXTRA_OECONF += "HOSTFW_YAML=${hostfw_datadir}/config.yaml"
46#
47# For now the generator requires them to already be combined so we have:
Deepak Kodihalli5b183e02017-02-20 04:55:20 -060048EXTRA_OECONF = " \
49 YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/config.yaml \
Ratan Guptadccf5ad2017-03-30 14:32:02 +053050 PROP_YAML=${STAGING_DIR_NATIVE}${properties_datadir}/extra-properties.yaml \
Deepak Kodihalli5b183e02017-02-20 04:55:20 -060051 "