blob: 9e407339a8e952e6b25ea6b24a3e5f4f2f433589 [file] [log] [blame]
Adriana Kobylak172fe102016-10-19 14:58:25 -05001SUMMARY = "Logging DBUS Object"
2DESCRIPTION = "Logging DBUS Object"
3HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
4PR = "r1"
5
6inherit autotools pkgconfig
7inherit pythonnative
8inherit obmc-phosphor-license
9inherit obmc-phosphor-dbus-service
Adriana Kobylakf40e1d82017-02-09 13:43:22 -060010inherit phosphor-dbus-interfaces
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050011inherit phosphor-logging
Adriana Kobylak172fe102016-10-19 14:58:25 -050012
13DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
14
15DEPENDS += "autoconf-archive-native"
16DEPENDS += "systemd"
17DEPENDS += "python-mako-native"
18DEPENDS += "python-pyyaml-native"
Patrick Williams57b17812016-12-09 08:56:38 -060019DEPENDS += "sdbusplus sdbusplus-native"
Deepak Kodihallic8d92052017-03-23 03:52:28 -050020DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050021DEPENDS += "virtual/phosphor-logging-callouts"
Adriana Kobylak78784092017-02-09 15:06:41 -060022RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
Adriana Kobylak172fe102016-10-19 14:58:25 -050023PROVIDES += "virtual/obmc-logging-mgmt"
24RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"
25
Michael Tritzccc0d0f2017-03-13 14:54:24 -050026PACKAGE_BEFORE_PN = "${PN}-test"
27FILES_${PN}-test = "${bindir}/*-test"
28
Adriana Kobylak172fe102016-10-19 14:58:25 -050029SRC_URI += "git://github.com/openbmc/phosphor-logging"
Patrick Williams80eb87a2017-05-29 20:40:05 -050030SRCREV = "1eb58922d3ca4fa61916accfd20fe0c28ac06430"
Adriana Kobylak172fe102016-10-19 14:58:25 -050031
32S = "${WORKDIR}/git"
33
Deepak Kodihalli2551ece2017-03-28 07:47:51 -050034PACKAGECONFIG ??= "metadata-processing"
35PACKAGECONFIG[metadata-processing] = " \
36 --enable-metadata-processing, \
37 --disable-metadata-processing, , \
38 "
39
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050040EXTRA_OECONF = " \
41 YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
42 CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
43 "