blob: 28b903db94e67f96b3b170604a42c427e1f14f56 [file] [log] [blame]
Brad Bishop667938f2017-01-12 21:44:51 -05001SUMMARY = "OpenBMC - Applications"
Brad Bishop93fb5352015-09-09 03:59:20 +00002PR = "r1"
3
4inherit packagegroup
Brad Bishop93fb5352015-09-09 03:59:20 +00005
Brad Bishop93fb5352015-09-09 03:59:20 +00006PROVIDES = "${PACKAGES}"
7PACKAGES = " \
Brad Bishop46631702017-03-01 16:16:06 -05008 ${PN}-bmc-state-mgmt \
9 ${PN}-chassis-state-mgmt \
Brad Bishop6165ec32016-09-06 22:44:21 -040010 ${PN}-extras \
11 ${PN}-extrasdev \
Adriana Kobylak0bce5322017-11-09 10:39:02 -060012 ${PN}-extrasdevtools \
Brad Bishop11909e02017-05-01 11:54:34 -040013 ${PN}-fan-control \
Brad Bishop46631702017-03-01 16:16:06 -050014 ${PN}-host-state-mgmt \
Brad Bishop45f8b572017-02-01 21:04:14 -050015 ${PN}-inventory \
16 ${PN}-leds \
Brad Bishop09486912018-03-23 13:07:46 -040017 ${PN}-logging \
Brad Bishop45f8b572017-02-01 21:04:14 -050018 ${PN}-sensors \
Gunnar Millsc868f922017-02-15 16:01:45 -060019 ${PN}-software \
Andrew Geisslera94faf42017-05-08 15:58:01 -050020 ${PN}-host-check-mgmt \
Jayanth Othayoth9963d172017-05-08 09:25:05 -050021 ${PN}-debug-collector \
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -050022 ${PN}-settings \
Ratan Guptab6de45c2017-07-06 21:09:14 +053023 ${PN}-network \
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +053024 ${PN}-user-mgmt \
Brad Bishop93fb5352015-09-09 03:59:20 +000025 "
26
Brad Bishop46631702017-03-01 16:16:06 -050027SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
28RDEPENDS_${PN}-bmc-state-mgmt = " \
29 ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \
30 "
31
32SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management"
33RDEPENDS_${PN}-chassis-state-mgmt = " \
34 ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
35 "
36
Brad Bishop6165ec32016-09-06 22:44:21 -040037SUMMARY_${PN}-extras = "Extra features"
38RDEPENDS_${PN}-extras = " \
Brad Bishop667938f2017-01-12 21:44:51 -050039 phosphor-rest \
Brad Bishopf1cc41b2017-05-31 14:08:33 -040040 phosphor-dbus-monitor \
Andrew Geissler65430332018-07-19 11:44:03 -070041 phosphor-systemd-policy \
Brad Bishop70436da2015-09-16 14:49:27 -040042 "
43
Brad Bishop6165ec32016-09-06 22:44:21 -040044SUMMARY_${PN}-extrasdev = "Development features"
45RDEPENDS_${PN}-extrasdev = " \
Adriana Kobylakeaa56c92016-06-16 14:46:06 -050046 rest-dbus \
47 "
Brad Bishop45f8b572017-02-01 21:04:14 -050048
Adriana Kobylak0bce5322017-11-09 10:39:02 -060049SUMMARY_${PN}-extrasdevtools = "Development tools"
50RDEPENDS_${PN}-extrasdevtools = " \
51 "
52
Brad Bishop11909e02017-05-01 11:54:34 -040053# Use the fan control package group for applications
54# implementing fan control or system fan policy only.
55# Applications that create inventory or sensors should
56# be added those respective package groups instead.
57SUMMARY_${PN}-fan-control = "Fan control"
58RDEPENDS_${PN}-fan-control = " \
Matt Spinlerbd9fdd92017-04-19 08:23:50 -050059 ${VIRTUAL-RUNTIME_obmc-fan-control} \
Matt Spinler39652c82017-05-01 14:29:20 -050060 phosphor-fan-monitor \
Brad Bishop11909e02017-05-01 11:54:34 -040061 "
62
Brad Bishop46631702017-03-01 16:16:06 -050063SUMMARY_${PN}-host-state-mgmt = "Host state management"
64RDEPENDS_${PN}-host-state-mgmt = " \
65 ${VIRTUAL-RUNTIME_obmc-host-state-manager} \
Michael Tritz1f792e02017-03-31 12:04:32 -050066 ${VIRTUAL-RUNTIME_obmc-discover-system-state} \
Brad Bishop46631702017-03-01 16:16:06 -050067 "
68
Brad Bishop45f8b572017-02-01 21:04:14 -050069SUMMARY_${PN}-inventory = "Inventory applications"
70RDEPENDS_${PN}-inventory = " \
71 ${VIRTUAL-RUNTIME_obmc-inventory-manager} \
Matthew Barth91460422017-02-24 13:14:43 -060072 ${VIRTUAL-RUNTIME_obmc-fan-presence} \
Brad Bishop45f8b572017-02-01 21:04:14 -050073 "
74
75SUMMARY_${PN}-leds = "LED applications"
76RDEPENDS_${PN}-leds = " \
Brad Bishopc1d30c52017-02-27 11:59:49 -050077 ${VIRTUAL-RUNTIME_obmc-leds-manager} \
78 ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \
Dhruvaraj Subhashchandrane1266ad2017-04-27 05:29:56 -050079 ${VIRTUAL-RUNTIME_obmc-led-monitor} \
Brad Bishop45f8b572017-02-01 21:04:14 -050080 "
81
Brad Bishop09486912018-03-23 13:07:46 -040082SUMMARY_${PN}-logging = "Logging applications"
83RDEPENDS_${PN}-logging = " \
84 phosphor-logging \
Deepak Kodihallia549e752018-08-21 06:40:53 -050085 rsyslog \
Deepak Kodihallif99f3c82018-08-28 11:39:41 -050086 phosphor-rsyslog-config \
Brad Bishop09486912018-03-23 13:07:46 -040087 "
88
Brad Bishop45f8b572017-02-01 21:04:14 -050089SUMMARY_${PN}-sensors = "Sensor applications"
90RDEPENDS_${PN}-sensors = " \
91 ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \
92 "
Gunnar Millsc868f922017-02-15 16:01:45 -060093
Brad Bishop811eeec2018-03-09 00:04:00 -050094# These packages are not required with UBI enabled
95${PN}-software-extras = " \
96 obmc-flash-bmc \
97 obmc-mgr-download \
98 "
99
Eddie James1a623ef2018-02-09 11:59:18 -0600100${PN}-software-extras_df-obmc-ubi-fs = " \
101 phosphor-image-signing \
Adriana Kobylak3aeee112018-06-04 13:06:52 -0500102 phosphor-software-manager-updater-ubi \
Eddie James1a623ef2018-02-09 11:59:18 -0600103 "
Brad Bishop811eeec2018-03-09 00:04:00 -0500104
Gunnar Millsc868f922017-02-15 16:01:45 -0600105SUMMARY_${PN}-software = "Software applications"
106RDEPENDS_${PN}-software = " \
Deepak Kodihalli60d1de52017-04-13 23:23:42 -0500107 ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \
Gunnar Mills30131f72017-05-15 15:40:58 -0500108 ${VIRTUAL-RUNTIME_obmc-bmc-updater} \
Andrew Geissler1f957522018-02-09 12:50:57 -0800109 ${VIRTUAL-RUNTIME_obmc-bmc-version} \
Brad Bishop811eeec2018-03-09 00:04:00 -0500110 ${${PN}-software-extras} \
Andrew Geissler1f957522018-02-09 12:50:57 -0800111 "
112
Jayanth Othayoth9963d172017-05-08 09:25:05 -0500113SUMMARY_${PN}-debug-collector = "BMC debug collector"
114RDEPENDS_${PN}-debug-collector = " \
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -0500115 ${VIRTUAL-RUNTIME_obmc-dump-manager} \
116 ${VIRTUAL-RUNTIME_obmc-dump-monitor} \
Jayanth Othayothd2592492017-07-29 22:28:44 -0500117 phosphor-debug-collector-dreport \
Marri Devender Rao33603922017-10-11 02:22:46 -0500118 phosphor-debug-collector-scripts \
Vishwanatha Subbanna14609cb2017-05-12 23:31:55 +0530119 "
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -0500120
121SUMMARY_${PN}-settings = "Settings applications"
122RDEPENDS_${PN}-settings = " \
Andrew Geissler78e04542018-02-05 12:02:35 -0800123 ${VIRTUAL-RUNTIME_obmc-settings-mgmt} \
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -0500124 "
Ratan Guptab6de45c2017-07-06 21:09:14 +0530125
126SUMMARY_${PN}-network = "BMC Network Manager"
127RDEPENDS_${PN}-network = " \
128 ${VIRTUAL-RUNTIME_obmc-network-manager} \
129 "
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +0530130
131SUMMARY_${PN}-user-mgmt = "User management applications"
132RDEPENDS_${PN}-user-mgmt = " \
133 ${VIRTUAL-RUNTIME_obmc-user-mgmt} \
Ratan Gupta4835bb32018-09-03 08:41:52 +0530134 ${@bb.utils.contains('DISTRO_FEATURES', 'ldap', 'nss-pam-ldapd', '', d)} \
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +0530135 "