blob: c3cd4e2be06da195110f185643408fc1edbcbfc1 [file] [log] [blame]
Matthew Barth91460422017-02-24 13:14:43 -06001SUMMARY = "Phosphor Fan Presence"
2DESCRIPTION = "Phosphor fan presence provides a set of fan presence \
3daemons to monitor fan presence changes by different methods of \
4presence detection."
Matthew Barth91460422017-02-24 13:14:43 -06005PR = "r1"
Matt Spinlerc943de32017-03-21 15:02:13 -05006
7require ${PN}.inc
Matthew Barth91460422017-02-24 13:14:43 -06008
9inherit autotools pkgconfig pythonnative
10inherit obmc-phosphor-systemd
Matt Spinlerc943de32017-03-21 15:02:13 -050011inherit phosphor-fan-presence
Matthew Barth91460422017-02-24 13:14:43 -060012
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "python-pyyaml-native"
Matt Spinlerc943de32017-03-21 15:02:13 -050015DEPENDS += "python-mako-native"
Matthew Barth91460422017-02-24 13:14:43 -060016DEPENDS += "sdbusplus"
17DEPENDS += "phosphor-logging"
Matt Spinlerc943de32017-03-21 15:02:13 -050018DEPENDS += "virtual/phosphor-fan-presence-config"
Brad Bishop96960aa2017-04-03 10:44:23 -040019DEPENDS += "libevdev"
Matthew Barth91460422017-02-24 13:14:43 -060020RDEPENDS_${PN} += "sdbusplus"
21
22FAN_PRESENCE_PACKAGES = " \
23 ${PN}-tach \
24"
25PACKAGES_remove = "${PN}"
26PACKAGES += "${FAN_PRESENCE_PACKAGES}"
27SYSTEMD_PACKAGES = "${FAN_PRESENCE_PACKAGES}"
28RDEPENDS_${PN}-dev = "${FAN_PRESENCE_PACKAGES}"
29
30# Needed to install into the obmc-chassis-start target
31TMPL = "phosphor-fan-presence-tach@.service"
32INSTFMT = "phosphor-fan-presence-tach@{0}.service"
33TGTFMT = "obmc-chassis-start@{0}.target"
34FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
35
36FILES_${PN}-tach = "${sbindir}/phosphor-fan-presence-tach"
37SYSTEMD_SERVICE_${PN}-tach += "${TMPL}"
38SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
39
Matthew Barth91460422017-02-24 13:14:43 -060040S = "${WORKDIR}/git"
Matt Spinlerc943de32017-03-21 15:02:13 -050041
42EXTRA_OECONF = \
43 "FAN_DETECT_YAML_FILE=${STAGING_DIR_NATIVE}${presence_datadir}/config.yaml"