Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor Fan Presence" |
| 2 | DESCRIPTION = "Phosphor fan presence provides a set of fan presence \ |
| 3 | daemons to monitor fan presence changes by different methods of \ |
| 4 | presence detection." |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 5 | PR = "r1" |
Matt Spinler | c943de3 | 2017-03-21 15:02:13 -0500 | [diff] [blame] | 6 | |
| 7 | require ${PN}.inc |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 8 | |
| 9 | inherit autotools pkgconfig pythonnative |
| 10 | inherit obmc-phosphor-systemd |
Matt Spinler | c943de3 | 2017-03-21 15:02:13 -0500 | [diff] [blame] | 11 | inherit phosphor-fan-presence |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 12 | |
| 13 | DEPENDS += "autoconf-archive-native" |
| 14 | DEPENDS += "python-pyyaml-native" |
Matt Spinler | c943de3 | 2017-03-21 15:02:13 -0500 | [diff] [blame] | 15 | DEPENDS += "python-mako-native" |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 16 | DEPENDS += "sdbusplus" |
| 17 | DEPENDS += "phosphor-logging" |
Matt Spinler | c943de3 | 2017-03-21 15:02:13 -0500 | [diff] [blame] | 18 | DEPENDS += "virtual/phosphor-fan-presence-config" |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 19 | RDEPENDS_${PN} += "sdbusplus" |
| 20 | |
| 21 | FAN_PRESENCE_PACKAGES = " \ |
| 22 | ${PN}-tach \ |
| 23 | " |
| 24 | PACKAGES_remove = "${PN}" |
| 25 | PACKAGES += "${FAN_PRESENCE_PACKAGES}" |
| 26 | SYSTEMD_PACKAGES = "${FAN_PRESENCE_PACKAGES}" |
| 27 | RDEPENDS_${PN}-dev = "${FAN_PRESENCE_PACKAGES}" |
| 28 | |
| 29 | # Needed to install into the obmc-chassis-start target |
| 30 | TMPL = "phosphor-fan-presence-tach@.service" |
| 31 | INSTFMT = "phosphor-fan-presence-tach@{0}.service" |
| 32 | TGTFMT = "obmc-chassis-start@{0}.target" |
| 33 | FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}" |
| 34 | |
| 35 | FILES_${PN}-tach = "${sbindir}/phosphor-fan-presence-tach" |
| 36 | SYSTEMD_SERVICE_${PN}-tach += "${TMPL}" |
| 37 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}" |
| 38 | |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 39 | S = "${WORKDIR}/git" |
Matt Spinler | c943de3 | 2017-03-21 15:02:13 -0500 | [diff] [blame] | 40 | |
| 41 | EXTRA_OECONF = \ |
| 42 | "FAN_DETECT_YAML_FILE=${STAGING_DIR_NATIVE}${presence_datadir}/config.yaml" |