Xo Wang | 0d917d8 | 2016-10-24 18:44:49 -0700 | [diff] [blame] | 1 | DESCRIPTION = "Command line tools for hardware device registers" |
Patrick Venture | 3896ac7 | 2017-10-05 15:11:30 -0700 | [diff] [blame] | 2 | HOMEPAGE = "https://github.com/jonmayergoogle/iotools" |
Xo Wang | 0d917d8 | 2016-10-24 18:44:49 -0700 | [diff] [blame] | 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
Brad Bishop | 56cbedf | 2018-03-30 12:27:37 -0400 | [diff] [blame] | 5 | SRCREV = "8d928b3360246b8ead95b442ca3887ce8b8f942f" |
Patrick Venture | 3896ac7 | 2017-10-05 15:11:30 -0700 | [diff] [blame] | 6 | SRC_URI = "git://git@github.com/jonmayergoogle/iotools.git;protocol=https" |
Xo Wang | 0d917d8 | 2016-10-24 18:44:49 -0700 | [diff] [blame] | 7 | PV = "v1.6+git${SRCPV}" |
| 8 | |
Patrick Venture | 54830d7 | 2017-10-05 16:25:40 -0700 | [diff] [blame] | 9 | inherit obmc-phosphor-systemd |
| 10 | |
Xo Wang | 0d917d8 | 2016-10-24 18:44:49 -0700 | [diff] [blame] | 11 | S = "${WORKDIR}/git" |
| 12 | FILES_${PN} = "${sbindir}" |
| 13 | |
| 14 | do_compile() { |
| 15 | # CC is overridden in the Makefile, so override it harder in the invocation |
| 16 | oe_runmake CC="${CC}" DEBUG="${DEBUG_BUILD-0}" STATIC=0 |
| 17 | } |
| 18 | |
| 19 | # The "install" make target runs the binary to create links for subcommands. |
| 20 | # The links are excessive and this doesn't work for cross compiling. |
| 21 | do_install() { |
| 22 | install -d ${D}${sbindir} |
| 23 | install -m 0755 iotools ${D}${sbindir} |
| 24 | } |
Patrick Venture | 54830d7 | 2017-10-05 16:25:40 -0700 | [diff] [blame] | 25 | |
| 26 | SYSTEMD_SERVICE_${PN} += "iotools-setup.service" |