blob: 539c2d92102eca8355052f8a96cbecddc2ba75aa [file] [log] [blame]
Sergey Solomin89eaea22016-08-16 14:18:18 -05001FILES_${PN}-catalog-extralocales = \
2 "${exec_prefix}/lib/systemd/catalog/*.*.catalog"
3PACKAGES =+ "${PN}-catalog-extralocales"
Adriana Kobylak20386eb2018-04-03 15:07:32 -05004PACKAGECONFIG_append = " networkd coredump"
Sergey Solomin89eaea22016-08-16 14:18:18 -05005PACKAGECONFIG_remove = "machined hibernate ldconfig binfmt backlight localed \
Joel Stanley2185c182018-02-23 14:22:20 +10306 quotacheck kdbus ima smack polkit logind bootchart utmp \
7 manpages"
Brad Bishopd4716b52015-10-30 03:02:05 -04008FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
9SRC_URI += "file://default.network"
Andrew Geissler51d40142017-09-07 14:32:45 -050010SRC_URI += "file://service-restart-policy.conf"
Brad Bishopbac8baf2018-02-25 22:55:05 -050011SRC_URI += "file://0001-sd-bus-Don-t-automatically-add-ObjectManager.patch"
Brad Bishopc8442242016-08-15 20:16:55 -040012SRC_URI += "file://0001-Export-message_append_cmdline.patch"
Edward A. James7875c7e2016-10-14 16:07:14 -050013SRC_URI += "file://0002-systemd-Make-pam-compile-shared-library.patch"
Brad Bishop5083ec32017-01-11 20:42:58 -050014SRC_URI += "file://0003-basic-Factor-out-string-checking-from-name_to_prefix.patch"
15SRC_URI += "file://0004-basic-Use-path-escaping-when-mangling-path-instances.patch"
Ratan Guptabd3edb72017-07-20 12:08:11 +053016#TODO upstream the below patch via below issue
17#https://github.com/openbmc/openbmc/issues/2016
18SRC_URI += "file://0005-dont-return-error-if-unable-to-create-network-namespace.patch"
Brad Bishop811eeec2018-03-09 00:04:00 -050019SRC_URI_append_df-obmc-ubi-fs = " file://software.conf"
Brad Bishopd4716b52015-10-30 03:02:05 -040020
Edward A. Jamesa0e634e2017-11-29 15:47:23 -060021SRC_URI += "file://0001-watchdog-allow-a-device-path-to-be-specified.patch"
22SRC_URI += "file://0002-core-Add-WatchdogDevice-config-option-and-implement-.patch"
23
Brad Bishope94b9152016-08-08 20:21:44 -040024RRECOMMENDS_${PN} += "obmc-targets"
Brad Bishop9b02b492018-06-07 19:53:58 -040025FILES_${PN} += "${systemd_unitdir}/network/default.network"
26FILES_${PN} += "${systemd_unitdir}/system.conf.d/service-restart-policy.conf"
Brad Bishopd4716b52015-10-30 03:02:05 -040027
Edward A. James561f6252016-08-04 16:19:18 -050028EXTRA_OECONF += " --disable-hwdb"
29
Brad Bishopd4716b52015-10-30 03:02:05 -040030do_install_append() {
Brad Bishop9b02b492018-06-07 19:53:58 -040031 install -m 644 ${WORKDIR}/default.network ${D}${systemd_unitdir}/network/
32 install -m 644 -D ${WORKDIR}/service-restart-policy.conf ${D}${systemd_unitdir}/system.conf.d/service-restart-policy.conf
Brad Bishop811eeec2018-03-09 00:04:00 -050033}
Gunnar Mills8b1ac4f2017-11-01 14:09:04 -050034
Brad Bishop811eeec2018-03-09 00:04:00 -050035do_install_append_df-obmc-ubi-fs() {
Gunnar Mills8b1ac4f2017-11-01 14:09:04 -050036 # /tmp/images is the software image upload directory.
37 # It should not be deleted since it is watched by the Image Manager
38 # for new images.
Brad Bishop811eeec2018-03-09 00:04:00 -050039 install -m 0644 ${WORKDIR}/software.conf ${D}${exec_prefix}/lib/tmpfiles.d/
Brad Bishopd4716b52015-10-30 03:02:05 -040040}