Adriana Kobylak | fa7c212 | 2015-10-19 14:15:04 -0400 | [diff] [blame] | 1 | SUMMARY = "Temp placeholder for skeleton function" |
| 2 | DESCRIPTION = "Temp placeholder for skeleton repository" |
| 3 | HOMEPAGE = "http://github.com/openbmc/skeleton" |
| 4 | PR = "r1" |
| 5 | |
| 6 | inherit obmc-phosphor-license |
| 7 | inherit obmc-phosphor-systemd |
Brad Bishop | 5a4b953 | 2015-10-21 20:24:23 -0400 | [diff] [blame] | 8 | inherit obmc-phosphor-chassis-mgmt |
Brad Bishop | 5a4b953 | 2015-10-21 20:24:23 -0400 | [diff] [blame] | 9 | inherit obmc-phosphor-fan-mgmt |
| 10 | inherit obmc-phosphor-flash-mgmt |
| 11 | inherit obmc-phosphor-policy-mgmt |
| 12 | inherit obmc-phosphor-sensor-mgmt |
| 13 | inherit obmc-phosphor-system-mgmt |
Brad Bishop | 2cd66df | 2016-06-14 21:33:22 -0400 | [diff] [blame] | 14 | inherit pythonnative |
| 15 | inherit python-dir |
Adriana Kobylak | fa7c212 | 2015-10-19 14:15:04 -0400 | [diff] [blame] | 16 | |
Brad Bishop | f5af3fe | 2016-06-09 22:22:46 -0400 | [diff] [blame] | 17 | VIRTUAL-RUNTIME_skeleton_workbook ?= "" |
| 18 | |
Brad Bishop | 0a27731 | 2016-06-15 22:01:33 -0400 | [diff] [blame] | 19 | DEPENDS += "glib-2.0 systemd python" |
Adriana Kobylak | be731de | 2016-06-18 07:52:44 -0500 | [diff] [blame] | 20 | RDEPENDS_${PN} += "python-json python-subprocess python-compression libsystemd ${VIRTUAL-RUNTIME_skeleton_workbook}" |
Adriana Kobylak | fa7c212 | 2015-10-19 14:15:04 -0400 | [diff] [blame] | 21 | SRC_URI += "git://github.com/openbmc/skeleton" |
Adriana Kobylak | fa7c212 | 2015-10-19 14:15:04 -0400 | [diff] [blame] | 22 | |
Brad Bishop | 2cd66df | 2016-06-14 21:33:22 -0400 | [diff] [blame] | 23 | FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/*" |
| 24 | |
Patrick Williams | aaf98c8 | 2016-04-01 15:04:31 -0500 | [diff] [blame] | 25 | # RDEPEND on pflash if the openpower-pflash machine feature is set. |
| 26 | PACKAGECONFIG ??= "${@bb.utils.contains('MACHINE_FEATURES', 'openpower-pflash', 'openpower-pflash', '', d)}" |
| 27 | PACKAGECONFIG[openpower-pflash] = ",,,pflash" |
| 28 | |
Adriana Kobylak | 33809de | 2016-06-24 16:14:08 -0500 | [diff] [blame] | 29 | SRCREV = "fa8f6166a05410472e8a3ef6a2f2e3b9b5f8d8e4" |
Adriana Kobylak | fa7c212 | 2015-10-19 14:15:04 -0400 | [diff] [blame] | 30 | |
Brad Bishop | b264b81 | 2015-10-28 08:13:43 -0500 | [diff] [blame] | 31 | S = "${WORKDIR}" |
Adriana Kobylak | fa7c212 | 2015-10-19 14:15:04 -0400 | [diff] [blame] | 32 | |
Brad Bishop | 2cd66df | 2016-06-14 21:33:22 -0400 | [diff] [blame] | 33 | # needed to invoke setuptools |
| 34 | export STAGING_INCDIR |
| 35 | export STAGING_LIBDIR |
| 36 | export BUILD_SYS |
| 37 | export HOST_SYS |
| 38 | export PYTHON_SITEPACKAGES_DIR |
Patrick Williams | aaf98c8 | 2016-04-01 15:04:31 -0500 | [diff] [blame] | 39 | |
Brad Bishop | 2cd66df | 2016-06-14 21:33:22 -0400 | [diff] [blame] | 40 | do_compile() { |
| 41 | oe_runmake -C git PYTHON=${PYTHON} |
Adriana Kobylak | fa7c212 | 2015-10-19 14:15:04 -0400 | [diff] [blame] | 42 | } |
| 43 | |
| 44 | do_install() { |
Brad Bishop | 2cd66df | 2016-06-14 21:33:22 -0400 | [diff] [blame] | 45 | oe_runmake -C git install \ |
Brad Bishop | f5af3fe | 2016-06-09 22:22:46 -0400 | [diff] [blame] | 46 | PYTHON=${PYTHON} \ |
| 47 | DESTDIR=${D} \ |
| 48 | PREFIX=/usr |
Adriana Kobylak | fa7c212 | 2015-10-19 14:15:04 -0400 | [diff] [blame] | 49 | } |