Vishwanatha Subbanna | 0803398 | 2017-01-09 15:00:38 +0530 | [diff] [blame] | 1 | SUMMARY = "Phosphor LED Group Management Daemon" |
| 2 | DESCRIPTION = "Daemon to cater to triggering actions on LED groups" |
Vishwanatha Subbanna | 0803398 | 2017-01-09 15:00:38 +0530 | [diff] [blame] | 3 | PR = "r1" |
Patrick Venture | 6dc4c9a | 2018-10-24 12:55:20 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Vishwanatha Subbanna | 0803398 | 2017-01-09 15:00:38 +0530 | [diff] [blame] | 5 | |
Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 6 | require ${PN}.inc |
Vishwanatha Subbanna | 0803398 | 2017-01-09 15:00:38 +0530 | [diff] [blame] | 7 | |
Dhruvaraj Subhashchandran | e1266ad | 2017-04-27 05:29:56 -0500 | [diff] [blame] | 8 | inherit autotools pkgconfig pythonnative |
| 9 | inherit obmc-phosphor-dbus-service obmc-phosphor-systemd |
| 10 | |
| 11 | LED_MGR_PACKAGES = " \ |
| 12 | ${PN}-ledmanager \ |
| 13 | ${PN}-faultmonitor \ |
| 14 | " |
| 15 | |
Brad Bishop | 196e1fc | 2018-04-11 11:43:28 -0400 | [diff] [blame] | 16 | PACKAGE_BEFORE_PN += "${LED_MGR_PACKAGES}" |
| 17 | ALLOW_EMPTY_${PN} = "1" |
Dhruvaraj Subhashchandran | e1266ad | 2017-04-27 05:29:56 -0500 | [diff] [blame] | 18 | |
| 19 | DBUS_PACKAGES = "${PN}-ledmanager" |
| 20 | |
| 21 | SYSTEMD_PACKAGES = "${LED_MGR_PACKAGES}" |
| 22 | |
Vishwanatha Subbanna | 0803398 | 2017-01-09 15:00:38 +0530 | [diff] [blame] | 23 | DEPENDS += "python-pyyaml-native" |
| 24 | DEPENDS += "autoconf-archive-native" |
| 25 | DEPENDS += "sdbusplus sdbusplus-native" |
Brad Bishop | 26873c9 | 2019-03-22 23:41:42 -0400 | [diff] [blame] | 26 | DEPENDS += "systemd" |
Ratan Gupta | 83fff10 | 2017-03-14 14:50:04 +0530 | [diff] [blame] | 27 | DEPENDS += "phosphor-logging" |
| 28 | |
Vishwanatha Subbanna | 8bec825 | 2017-02-11 22:10:23 +0530 | [diff] [blame] | 29 | DEPENDS += "virtual/${PN}-config-native" |
Vishwanatha Subbanna | 0803398 | 2017-01-09 15:00:38 +0530 | [diff] [blame] | 30 | |
Vishwanatha Subbanna | 0803398 | 2017-01-09 15:00:38 +0530 | [diff] [blame] | 31 | S = "${WORKDIR}/git" |
| 32 | |
Andrew Geissler | 5c9bbc1 | 2019-03-28 20:52:34 +0000 | [diff] [blame] | 33 | FILES_${PN}-ledmanager += "${bindir}/phosphor-ledmanager" |
| 34 | FILES_${PN}-faultmonitor += "${bindir}/phosphor-fru-fault-monitor" |
Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 35 | |
Dhruvaraj Subhashchandran | e1266ad | 2017-04-27 05:29:56 -0500 | [diff] [blame] | 36 | DBUS_SERVICE_${PN}-ledmanager += "xyz.openbmc_project.LED.GroupManager.service" |
| 37 | |
| 38 | SYSTEMD_SERVICE_${PN}-ledmanager += "obmc-led-group-start@.service obmc-led-group-stop@.service" |
| 39 | SYSTEMD_SERVICE_${PN}-faultmonitor += "obmc-fru-fault-monitor.service" |
| 40 | |
Patrick Venture | d607cfb | 2019-04-04 12:15:22 -0700 | [diff] [blame] | 41 | SYSTEMD_LINK_${PN}-ledmanager += "../obmc-led-group-start@.service:multi-user.target.wants/obmc-led-group-start@bmc_booted.service" |
Vishwanatha Subbanna | a075b96 | 2017-03-27 14:36:58 +0530 | [diff] [blame] | 42 | |
| 43 | STATES = "start stop" |
| 44 | TMPLFMT = "obmc-led-group-{0}@.service" |
| 45 | TGTFMT = "obmc-power-{0}@0.target" |
| 46 | INSTFMT = "obmc-led-group-{0}@power_on.service" |
| 47 | FMT = "../${TMPLFMT}:${TGTFMT}.wants/${INSTFMT}" |
Dhruvaraj Subhashchandran | e1266ad | 2017-04-27 05:29:56 -0500 | [diff] [blame] | 48 | SYSTEMD_LINK_${PN}-ledmanager += "${@compose_list(d, 'FMT', 'STATES')}" |
| 49 | |
Vishwanatha Subbanna | 51f391d | 2017-07-19 02:25:13 -0500 | [diff] [blame] | 50 | # Install the override to set up a Conflicts relation |
| 51 | SYSTEMD_OVERRIDE_${PN}-ledmanager += "bmc_booted.conf:obmc-led-group-start@bmc_booted.service.d/bmc_booted.conf" |
Vishwanatha Subbanna | a075b96 | 2017-03-27 14:36:58 +0530 | [diff] [blame] | 52 | |
Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 53 | EXTRA_OECONF = "YAML_PATH=${STAGING_DATADIR_NATIVE}/${PN}" |