Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 1 | SUMMARY = "C++ bindings for systemd dbus APIs" |
| 2 | DESCRIPTION = "C++ bindings for systemd dbus APIs." |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 3 | |
| 4 | inherit autotools pkgconfig |
Patrick Williams | 11d5972 | 2020-02-24 16:29:47 -0600 | [diff] [blame] | 5 | inherit obmc-phosphor-python3-autotools |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 6 | |
Patrick Williams | 2544884 | 2020-03-31 12:51:05 -0500 | [diff] [blame] | 7 | include sdbusplus-rev.inc |
| 8 | |
Nagaraju Goruganti | 78077a5 | 2017-08-22 05:24:26 -0500 | [diff] [blame] | 9 | DEPENDS += " \ |
| 10 | autoconf-archive-native \ |
Patrick Williams | 4cd2243 | 2020-02-24 16:27:10 -0600 | [diff] [blame] | 11 | ${PYTHON_PN}-inflection-native \ |
| 12 | ${PYTHON_PN}-mako-native \ |
| 13 | ${PYTHON_PN}-pyyaml-native \ |
Nagaraju Goruganti | 78077a5 | 2017-08-22 05:24:26 -0500 | [diff] [blame] | 14 | " |
Brad Bishop | 32f0a9a | 2017-01-18 13:59:33 -0500 | [diff] [blame] | 15 | |
Adriana Kobylak | 178d6b5 | 2017-02-12 17:40:26 -0600 | [diff] [blame] | 16 | PACKAGECONFIG ??= "libsdbusplus transaction" |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 17 | PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd" |
Adriana Kobylak | 178d6b5 | 2017-02-12 17:40:26 -0600 | [diff] [blame] | 18 | PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction" |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 19 | |
Patrick Williams | 7aba815 | 2020-03-31 14:22:32 -0500 | [diff] [blame] | 20 | # Remove unused sdbus++ contents (included in python3-sdbus++ package). |
| 21 | do_install_append() { |
| 22 | rm ${D}/${bindir}/sdbus++ |
| 23 | rmdir ${D}/${bindir} || true |
| 24 | rm -rf ${D}/${PYTHON_SITEPACKAGES_DIR} |
| 25 | rmdir ${D}/${libdir}/${PYTHON_DIR} || true |
| 26 | } |