blob: 87eb1414361f480c1c91ec35428e2c44c2a22324 [file] [log] [blame]
Chris Austen213cd2a2015-10-24 19:34:11 -05001SUMMARY = "Phosphor OpenBMC OEM Commands for OpenPOWER systems"
2DESCRIPTION = "Phosphor OpenBMC IPMI OEM commands for OpenPOWER based systems"
3HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-oem"
4PR = "r1"
5
Chris Austen213cd2a2015-10-24 19:34:11 -05006inherit obmc-phosphor-license
7
8DEPENDS += "systemd \
Brad Bishop1b8e41a2016-09-08 17:06:59 -04009 host-ipmid \
10 "
Chris Austen254cb562016-01-23 18:00:11 -060011TARGET_CFLAGS += "-fpic"
Chris Austen213cd2a2015-10-24 19:34:11 -050012
13
14RDEPENDS_${PN} += "libsystemd"
15
16
17
18SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-oem"
19
Patrick Williams10d86c02016-08-30 11:50:03 -050020SRCREV = "e74fc6bb9221663b1875332944b2f383e39d9a12"
Chris Austen213cd2a2015-10-24 19:34:11 -050021
22FILES_${PN} += "${libdir}/host-ipmid/*.so"
23FILES_${PN}-dbg += "${libdir}/host-ipmid/.debug"
24
25S = "${WORKDIR}/git"
26
Brad Bishop1b8e41a2016-09-08 17:06:59 -040027do_install() {
Chris Austen213cd2a2015-10-24 19:34:11 -050028 install -m 0755 -d ${D}${libdir}/host-ipmid
29 install -m 0755 ${S}/*.so ${D}${libdir}/host-ipmid/
30}