Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 1 | SUMMARY = "Logging DBUS Object" |
| 2 | DESCRIPTION = "Logging DBUS Object" |
| 3 | HOMEPAGE = "https://github.com/openbmc/phosphor-logging" |
| 4 | PR = "r1" |
| 5 | |
| 6 | inherit autotools pkgconfig |
| 7 | inherit pythonnative |
| 8 | inherit obmc-phosphor-license |
| 9 | inherit obmc-phosphor-dbus-service |
Adriana Kobylak | f40e1d8 | 2017-02-09 13:43:22 -0600 | [diff] [blame] | 10 | inherit phosphor-dbus-interfaces |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 11 | inherit phosphor-logging |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 12 | |
| 13 | DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service" |
| 14 | |
| 15 | DEPENDS += "autoconf-archive-native" |
| 16 | DEPENDS += "systemd" |
| 17 | DEPENDS += "python-mako-native" |
| 18 | DEPENDS += "python-pyyaml-native" |
Patrick Williams | 57b1781 | 2016-12-09 08:56:38 -0600 | [diff] [blame] | 19 | DEPENDS += "sdbusplus sdbusplus-native" |
Deepak Kodihalli | c8d9205 | 2017-03-23 03:52:28 -0500 | [diff] [blame] | 20 | DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native" |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 21 | DEPENDS += "virtual/phosphor-logging-callouts" |
Adriana Kobylak | 7878409 | 2017-02-09 15:06:41 -0600 | [diff] [blame] | 22 | RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 23 | PROVIDES += "virtual/obmc-logging-mgmt" |
| 24 | RPROVIDES_${PN} += "virtual-obmc-logging-mgmt" |
| 25 | |
Michael Tritz | ccc0d0f | 2017-03-13 14:54:24 -0500 | [diff] [blame] | 26 | PACKAGE_BEFORE_PN = "${PN}-test" |
| 27 | FILES_${PN}-test = "${bindir}/*-test" |
| 28 | |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 29 | SRC_URI += "git://github.com/openbmc/phosphor-logging" |
Patrick Williams | b1bcb11 | 2017-03-29 13:30:06 -0500 | [diff] [blame] | 30 | SRCREV = "58f16f7e3a60e05a04e25c0a7e363757b65e72d5" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 31 | |
| 32 | S = "${WORKDIR}/git" |
| 33 | |
Deepak Kodihalli | 2551ece | 2017-03-28 07:47:51 -0500 | [diff] [blame] | 34 | PACKAGECONFIG ??= "metadata-processing" |
| 35 | PACKAGECONFIG[metadata-processing] = " \ |
| 36 | --enable-metadata-processing, \ |
| 37 | --disable-metadata-processing, , \ |
| 38 | " |
| 39 | |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 40 | EXTRA_OECONF = " \ |
| 41 | YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \ |
| 42 | CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \ |
| 43 | " |