blob: 2ab7ce5f0376e4a0e2f0a0f0aa9b9bf195b3790d [file] [log] [blame]
Chris Austen737b35f2015-10-25 00:21:04 -05001SUMMARY = "Phosphor OpenBMC Event Management"
2DESCRIPTION = "Phosphor OpenBMC event management reference implementation."
Chris Austen3fef0762015-10-30 15:59:47 -05003HOMEPAGE = "https://github.com/openbmc/phosphor-event"
Chris Austen737b35f2015-10-25 00:21:04 -05004PR = "r1"
5
6
7inherit obmc-phosphor-license
8inherit obmc-phosphor-event-mgmt
9inherit obmc-phosphor-sdbus-service
10inherit obmc-phosphor-c-daemon
11
Chris Austene6be0e32016-02-08 23:00:29 -060012TARGET_CPPFLAGS += "-std=c++11 -fpic"
Chris Austen737b35f2015-10-25 00:21:04 -050013
Chris Austen3fef0762015-10-30 15:59:47 -050014SRC_URI += "git://github.com/openbmc/phosphor-event"
Sergey Solomin2461f3c2016-08-15 14:21:08 -050015SRC_URI += "file://eventd.conf"
Chris Austen3fef0762015-10-30 15:59:47 -050016
Patrick Williams75de7b82016-08-13 09:04:15 -050017SRCREV = "4dad23916e69d55d692eca7389d67eb023c5ca66"
Chris Austen737b35f2015-10-25 00:21:04 -050018
19RDEPENDS_${PN} += "libsystemd"
20DEPENDS += "systemd"
21
22
23S = "${WORKDIR}/git"
24INSTALL_NAME = "event_messaged"
25
26do_install() {
Chris Austene6be0e32016-02-08 23:00:29 -060027 install -d ${D}/var/lib/obmc/events/
Chris Austen737b35f2015-10-25 00:21:04 -050028 install -m 0755 -d ${D}${sbindir}
29 install -m 0755 ${S}/${INSTALL_NAME} ${D}/${sbindir}/obmc-phosphor-eventd
Sergey Solomin2461f3c2016-08-15 14:21:08 -050030 install -m 0755 -d ${D}${sysconfdir}/default/eventd
31 install -m 0644 ${WORKDIR}/eventd.conf ${D}${sysconfdir}/default/eventd/eventd.conf
Chris Austen737b35f2015-10-25 00:21:04 -050032}