blob: 56df13bdda4e23a8fecbb6674a1aa3291bdfa3dd [file] [log] [blame]
vishwabmc1bf499d2015-10-09 15:51:50 +05301SUMMARY = "Phosphor OpenBMC IPMI daemon"
2DESCRIPTION = "Phosphor OpenBMC IPMI router and plugin libraries"
vishwabmc1bf499d2015-10-09 15:51:50 +05303PR = "r1"
Patrick Venturef30b8842018-10-21 08:27:22 -07004PV = "1.0+git${SRCPV}"
Patrick Venture64329372018-11-03 09:42:59 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
vishwabmc1bf499d2015-10-09 15:51:50 +05307
Brad Bishop7ee71462016-08-19 09:02:54 -05008RRECOMMENDS_${PN} += "packagegroup-obmc-ipmid-providers-libs"
Chris Austen213cd2a2015-10-24 19:34:11 -05009
Matthew Barth302592f2016-08-16 16:51:35 -050010inherit autotools pkgconfig
Patrick Ventured3dd0942017-12-22 14:36:07 -080011inherit obmc-phosphor-ipmiprovider-symlink
Patrick Williamsf7714062015-10-15 15:20:20 -050012inherit obmc-phosphor-sdbus-service
Patrick Ventured3dd0942017-12-22 14:36:07 -080013inherit obmc-phosphor-systemd
Ratan Guptab92d0ec2017-03-06 17:05:11 +053014inherit phosphor-ipmi-host
Andrew Geissler06fe9692020-03-30 14:31:19 +000015inherit python3native
vishwabmc1bf499d2015-10-09 15:51:50 +053016
Brad Bishop7f2ade02018-01-26 22:11:36 -050017def ipmi_whitelists(d):
18 whitelists = d.getVar(
19 'VIRTUAL-RUNTIME_phosphor-ipmi-providers', True) or ''
20 whitelists = whitelists.split()
21 whitelists = [ '{}-whitelist-native'.format(x) for x in whitelists ]
22 return ' '.join(whitelists)
23
Patrick Ventured3dd0942017-12-22 14:36:07 -080024DEPENDS += "autoconf-archive-native"
David Cobbley1dc78fb2017-11-21 16:17:40 -080025DEPENDS += "nlohmann-json"
Andrew Geissler77cfb0f2020-01-14 14:21:24 -060026DEPENDS += "phosphor-state-manager"
Brad Bishop7f2ade02018-01-26 22:11:36 -050027DEPENDS += "${@ipmi_whitelists(d)}"
Patrick Ventured3dd0942017-12-22 14:36:07 -080028DEPENDS += "phosphor-dbus-interfaces"
Adriana Kobylak17885c22017-02-17 08:21:42 -060029DEPENDS += "phosphor-logging"
Brad Bishop1122eb02016-10-05 20:10:23 -040030DEPENDS += "phosphor-mapper"
Ratan Gupta8dc22a92017-03-20 18:20:47 +053031DEPENDS += "sdbusplus"
Patrick Williams2bebd122020-03-31 16:43:15 -050032DEPENDS += "${PYTHON_PN}-sdbus++-native"
Tom Josephc32034f2019-02-04 03:54:06 -060033DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
Marri Devender Rao5a0088c2017-07-26 02:11:32 -050034DEPENDS += "virtual/phosphor-ipmi-fru-merge-config"
Patrick Ventured3dd0942017-12-22 14:36:07 -080035DEPENDS += "virtual/phosphor-ipmi-sensor-inventory"
Andrew Geisslera561ec92018-09-25 19:50:20 +000036DEPENDS += "boost"
Patrick Venture12a94a82018-11-07 17:48:53 -080037DEPENDS += "sdeventplus"
Tom Joseph6c283fc2020-03-05 10:08:45 -060038DEPENDS += "${PYTHON_PN}-native"
39DEPENDS += "${PYTHON_PN}-pyyaml-native"
40DEPENDS += "${PYTHON_PN}-mako-native"
Ratan Guptab92d0ec2017-03-06 17:05:11 +053041
Andrew Jeffery381e1e92018-04-06 14:13:14 +093042VIRTUAL-RUNTIME_ipmi-config ?= "phosphor-ipmi-config"
43
Adriana Kobylak17885c22017-02-17 08:21:42 -060044RDEPENDS_${PN}-dev += "phosphor-logging"
Brad Bishop1122eb02016-10-05 20:10:23 -040045RDEPENDS_${PN}-dev += "phosphor-mapper-dev"
Milton D. Miller II611e3ff2016-03-04 15:29:29 -060046RDEPENDS_${PN} += "clear-once"
Patrick Venture98fa9612019-03-28 09:09:13 -070047RDEPENDS_${PN} += "phosphor-network"
Vishwanatha Subbanna78bc5422016-11-10 21:52:46 +053048RDEPENDS_${PN} += "phosphor-time-manager"
Andrew Jeffery381e1e92018-04-06 14:13:14 +093049RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_ipmi-config}"
Vishwanatha Subbanna55c545a2017-06-12 13:09:10 +053050RDEPENDS_${PN} += "virtual/obmc-watchdog"
Patrick Venture68f12612019-04-30 10:26:34 -070051RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_obmc-bmc-state-manager}"
Patrick Venture00e88bf2019-05-03 07:51:58 -070052RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_obmc-bmc-version}"
Patrick Venturef5dd0312019-05-03 07:53:57 -070053RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_obmc-bmc-updater}"
Ratan Gupta8dc22a92017-03-20 18:20:47 +053054
Richard Marian Thomaiyarfe5b8d22018-08-20 20:14:16 +053055inherit useradd
56
57USERADD_PACKAGES = "${PN}"
58# add ipmi group
59GROUPADD_PARAM_${PN} = "ipmi"
60
Vishwanatha Subbanna35318402017-03-31 14:41:11 +053061SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service phosphor-ipmi-host.service"
62
Brad Bishopa71cf482020-03-19 16:14:54 -040063RRECOMMENDS_${PN} += "phosphor-settings-manager"
Andrew Geissler78e04542018-02-05 12:02:35 -080064
vishwabmc1bf499d2015-10-09 15:51:50 +053065
Patrick Williamsc7d848e2020-04-03 15:48:30 -050066require ${BPN}.inc
Chris Austen213cd2a2015-10-24 19:34:11 -050067
Tom Josephf07ae012017-02-20 12:01:43 +053068# Setup IPMI Whitelist Conf files
69WHITELIST_CONF = " \
Patrick Williamsf11f0152017-02-24 13:04:06 -060070 ${STAGING_DATADIR_NATIVE}/phosphor-ipmi-host/*.conf \
Tom Josephf07ae012017-02-20 12:01:43 +053071 ${S}/host-ipmid-whitelist.conf \
72 "
73EXTRA_OECONF = " \
Ratan Guptab92d0ec2017-03-06 17:05:11 +053074 SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor.yaml \
Tom Josephc32034f2019-02-04 03:54:06 -060075 INVSENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/invsensor.yaml \
Marri Devender Rao5a0088c2017-07-26 02:11:32 -050076 FRU_YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/fru_config.yaml \
Tom Josephf07ae012017-02-20 12:01:43 +053077 "
Brad Bishopbb60cff2019-06-09 22:57:35 -040078EXTRA_OECONF_append = " \
79 WHITELIST_CONF="${WHITELIST_CONF}" \
80 "
Tom Josephf07ae012017-02-20 12:01:43 +053081
vishwabmc1bf499d2015-10-09 15:51:50 +053082S = "${WORKDIR}/git"
83
Andrew Jeffery381e1e92018-04-06 14:13:14 +093084SRC_URI += "file://merge_yamls.py "
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -050085
Vernon Mauery595c7382018-07-30 15:49:09 -070086HOSTIPMI_PROVIDER_LIBRARY += "libipmi20.so"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053087HOSTIPMI_PROVIDER_LIBRARY += "libsysintfcmds.so"
William A. Kennington IIIc426a982018-12-19 14:53:22 -080088HOSTIPMI_PROVIDER_LIBRARY += "libusercmds.so"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053089
Vernon Mauery595c7382018-07-30 15:49:09 -070090NETIPMI_PROVIDER_LIBRARY += "libipmi20.so"
William A. Kennington IIIc426a982018-12-19 14:53:22 -080091NETIPMI_PROVIDER_LIBRARY += "libusercmds.so"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053092
Matthew Barth302592f2016-08-16 16:51:35 -050093FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Patrick Ventured3dd0942017-12-22 14:36:07 -080094FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053095FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
96FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Brad Bishop3b524cf2016-09-06 13:03:39 -040097
Andrew Geisslerafc510f2017-01-04 11:11:50 -060098# Soft Power Off
Andrew Geisslerd40db752017-05-11 16:16:27 -050099# install the soft power off service in the host shutdown target
100SOFT_SVC = "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service"
101SOFT_TGTFMT = "obmc-host-shutdown@{0}.target"
102SOFT_FMT = "../${SOFT_SVC}:${SOFT_TGTFMT}.requires/${SOFT_SVC}"
103SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'SOFT_FMT', 'OBMC_HOST_INSTANCES')}"
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500104
105#Collect all hardcoded sensor yamls from different recipes and
106#merge all of them with sensor.yaml.
107python do_merge_sensors () {
108 import subprocess
109
110 # TODO: Perform the merge in a temporary directory?
111 workdir = d.getVar('WORKDIR', True)
112 nativedir = d.getVar('STAGING_DIR_NATIVE', True)
113 sensorsdir = d.getVar('sensor_datadir', True)
114 sensorsdir = sensorsdir[1:]
115 sensorsdir = os.path.join(nativedir, sensorsdir)
116 cmd = []
117 cmd.append(os.path.join(workdir, 'merge_yamls.py'))
118 cmd.append(os.path.join(sensorsdir, 'sensor.yaml'))
119
120 if os.stat(os.path.join(sensorsdir, 'sensor.yaml')).st_size == 0:
121 return
122 fetch = bb.fetch2.Fetch([], d)
Kun Yie6bd58c2017-10-09 23:17:08 -0700123 override_urls = [url for url in fetch.urls if url.endswith('.hardcoded.yaml')]
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500124 for url in override_urls:
125 bb.debug(2, 'Overriding with source: ' + url)
126 local_base = os.path.basename(fetch.localpath(url))
127 filename = os.path.join(workdir, local_base)
128 cmd.append(filename)
129
130 # Invoke the script and don't catch any resulting exception.
131 subprocess.check_call(cmd)
132}
Andrew Jeffery381e1e92018-04-06 14:13:14 +0930133
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500134# python-pyyaml-native is installed by do_configure, so put this task after
135addtask merge_sensors after do_configure before do_compile