Brad Bishop | ff7bf4b | 2017-01-17 09:14:15 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor IPMI Inventory Plugin" |
| 2 | DESCRIPTION = "A Phosphor IPMI plugin that updates inventory." |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 3 | PR = "r1" |
| 4 | |
Matthew Barth | 2c455f0 | 2016-10-19 16:00:49 -0500 | [diff] [blame] | 5 | inherit autotools pkgconfig |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 6 | inherit obmc-phosphor-systemd |
Tom Joseph | 40b4e3f | 2017-02-01 19:47:27 +0530 | [diff] [blame] | 7 | inherit obmc-phosphor-ipmiprovider-symlink |
Brad Bishop | 2c5db6a | 2017-01-28 13:00:52 -0500 | [diff] [blame] | 8 | inherit phosphor-ipmi-fru |
| 9 | inherit pythonnative |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 10 | |
Brad Bishop | ee06461 | 2017-01-17 10:10:02 -0500 | [diff] [blame] | 11 | require ${PN}.inc |
| 12 | |
Brad Bishop | dd2e4fa | 2016-06-13 12:53:41 -0400 | [diff] [blame] | 13 | DEPENDS += " \ |
Brad Bishop | 2c5db6a | 2017-01-28 13:00:52 -0500 | [diff] [blame] | 14 | virtual/phosphor-ipmi-fru-hostfw-config\ |
| 15 | virtual/phosphor-ipmi-fru-inventory \ |
Brad Bishop | dd2e4fa | 2016-06-13 12:53:41 -0400 | [diff] [blame] | 16 | systemd \ |
Brad Bishop | 2c5db6a | 2017-01-28 13:00:52 -0500 | [diff] [blame] | 17 | python-mako-native \ |
| 18 | python-pyyaml-native \ |
Brad Bishop | c30d7bb | 2017-01-17 10:07:14 -0500 | [diff] [blame] | 19 | phosphor-ipmi-host \ |
Matthew Barth | 2c455f0 | 2016-10-19 16:00:49 -0500 | [diff] [blame] | 20 | phosphor-mapper \ |
| 21 | autoconf-archive-native \ |
Brad Bishop | dd2e4fa | 2016-06-13 12:53:41 -0400 | [diff] [blame] | 22 | " |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 23 | |
| 24 | RDEPENDS_${PN} += "libsystemd" |
| 25 | |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 26 | SYSTEMD_SERVICE_${PN} += "obmc-read-eeprom@.service" |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 27 | |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 28 | S = "${WORKDIR}/git" |
| 29 | |
Tom Joseph | 40b4e3f | 2017-02-01 19:47:27 +0530 | [diff] [blame] | 30 | HOSTIPMI_PROVIDER_LIBRARY += "libstrgfnhandler.so" |
| 31 | |
| 32 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
Matthew Barth | 2c455f0 | 2016-10-19 16:00:49 -0500 | [diff] [blame] | 33 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
Tom Joseph | 40b4e3f | 2017-02-01 19:47:27 +0530 | [diff] [blame] | 34 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
Brad Bishop | 2c5db6a | 2017-01-28 13:00:52 -0500 | [diff] [blame] | 35 | |
| 36 | # TODO: Fix the the ipmi-fru-parser code generator to handle split |
| 37 | # host firmware / inventory YAML and replace the OECONF below with: |
| 38 | # |
| 39 | # EXTRA_OECONF += "INVENTORY_YAML=${inventory_datadir}/config.yaml" |
| 40 | # EXTRA_OECONF += "HOSTFW_YAML=${hostfw_datadir}/config.yaml" |
| 41 | # |
| 42 | # For now the generator requires them to already be combined so we have: |
| 43 | EXTRA_OECONF = "YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/config.yaml" |