blob: 76ba70e502b31b8444eb5f6666b1b480447c2b75 [file] [log] [blame]
Jeremy Kerr49208ee2016-03-17 17:35:27 +08001SUMMARY = "OpenBMC console daemon"
2DESCRIPTION = "Daemon to handle UART console connections"
3HOMEPAGE = "http://github.com/openbmc/obmc-console"
4PR = "r1"
Patrick Venturee7a76eb2018-11-03 09:41:57 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
Jeremy Kerr49208ee2016-03-17 17:35:27 +08007
Jeremy Kerr49208ee2016-03-17 17:35:27 +08008inherit obmc-phosphor-systemd
9inherit autotools
Ratan Gupta653779c2016-10-01 14:57:15 -050010inherit obmc-phosphor-discovery-service
Jeremy Kerr49208ee2016-03-17 17:35:27 +080011
12TARGET_CFLAGS += "-fpic -O2"
13
Matthew Barth3cc6f402016-09-26 16:26:27 -050014DEPENDS += "autoconf-archive-native"
15
Jeremy Kerr49208ee2016-03-17 17:35:27 +080016SRC_URI += "git://github.com/openbmc/obmc-console"
Brad Bishop530eb732016-08-30 14:14:24 -040017SRC_URI += "file://${PN}.conf"
Jeremy Kerred9fafd2016-04-12 13:10:12 +080018
Andrew Geisslerf21ad252018-09-07 01:50:15 +000019SRCREV = "1864435759305800aeda41fc3e37baceb5762116"
Brad Bishopbd6ae762018-04-12 11:11:49 -040020PV = "1.0+git${SRCPV}"
Jeremy Kerr49208ee2016-03-17 17:35:27 +080021
Ratan Gupta653779c2016-10-01 14:57:15 -050022REGISTERED_SERVICES_${PN} += "obmc_console:tcp:2200"
Vishwanatha Subbanna5f3a19b2016-10-01 11:34:42 -050023OBMC_CONSOLE_HOST_TTY ?= "ttyVUART0"
24SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh@.service"
Yi Li75ff3b92016-10-21 12:08:47 +080025SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh.socket"
Ratan Gupta653779c2016-10-01 14:57:15 -050026
Brad Bishop530eb732016-08-30 14:14:24 -040027SYSTEMD_SERVICE_${PN} = " \
Vishwanatha Subbanna5f3a19b2016-10-01 11:34:42 -050028 ${PN}@.service \
29 ${PN}@${OBMC_CONSOLE_HOST_TTY}.service \
Brad Bishop530eb732016-08-30 14:14:24 -040030 ${PN}-ssh.socket \
31 ${PN}-ssh@.service \
32 "
Jeremy Kerr49208ee2016-03-17 17:35:27 +080033do_install_append() {
34 install -m 0755 -d ${D}${sysconfdir}
35 install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
Jeremy Kerr49208ee2016-03-17 17:35:27 +080036}
37
38S = "${WORKDIR}/git"