blob: d6f8c8f1a875261556a48bd9bd5e0c35092827b3 [file] [log] [blame]
Brad Bishopff7bf4b2017-01-17 09:14:15 -05001SUMMARY = "Phosphor IPMI Inventory Plugin"
2DESCRIPTION = "A Phosphor IPMI plugin that updates inventory."
Chris Austenf7cefb12015-11-01 22:27:34 -06003PR = "r1"
4
Matthew Barth2c455f02016-10-19 16:00:49 -05005inherit autotools pkgconfig
Brad Bishop0fe80462016-08-17 20:27:37 -04006inherit obmc-phosphor-systemd
Tom Joseph40b4e3f2017-02-01 19:47:27 +05307inherit obmc-phosphor-ipmiprovider-symlink
Brad Bishop2c5db6a2017-01-28 13:00:52 -05008inherit phosphor-ipmi-fru
9inherit pythonnative
Chris Austenf7cefb12015-11-01 22:27:34 -060010
Brad Bishopee064612017-01-17 10:10:02 -050011require ${PN}.inc
12
Brad Bishopdd2e4fa2016-06-13 12:53:41 -040013DEPENDS += " \
Brad Bishop2c5db6a2017-01-28 13:00:52 -050014 virtual/phosphor-ipmi-fru-hostfw-config\
15 virtual/phosphor-ipmi-fru-inventory \
Brad Bishopdd2e4fa2016-06-13 12:53:41 -040016 systemd \
Brad Bishop2c5db6a2017-01-28 13:00:52 -050017 python-mako-native \
18 python-pyyaml-native \
Brad Bishopc30d7bb2017-01-17 10:07:14 -050019 phosphor-ipmi-host \
Matthew Barth2c455f02016-10-19 16:00:49 -050020 phosphor-mapper \
21 autoconf-archive-native \
Brad Bishopdd2e4fa2016-06-13 12:53:41 -040022 "
Chris Austenf7cefb12015-11-01 22:27:34 -060023
24RDEPENDS_${PN} += "libsystemd"
25
Brad Bishop0fe80462016-08-17 20:27:37 -040026SYSTEMD_SERVICE_${PN} += "obmc-read-eeprom@.service"
Chris Austenf7cefb12015-11-01 22:27:34 -060027
Chris Austenf7cefb12015-11-01 22:27:34 -060028S = "${WORKDIR}/git"
29
Tom Joseph40b4e3f2017-02-01 19:47:27 +053030HOSTIPMI_PROVIDER_LIBRARY += "libstrgfnhandler.so"
31
32FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Matthew Barth2c455f02016-10-19 16:00:49 -050033FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053034FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Brad Bishop2c5db6a2017-01-28 13:00:52 -050035
36# TODO: Fix the the ipmi-fru-parser code generator to handle split
37# host firmware / inventory YAML and replace the OECONF below with:
38#
39# EXTRA_OECONF += "INVENTORY_YAML=${inventory_datadir}/config.yaml"
40# EXTRA_OECONF += "HOSTFW_YAML=${hostfw_datadir}/config.yaml"
41#
42# For now the generator requires them to already be combined so we have:
43EXTRA_OECONF = "YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/config.yaml"