blob: 16e26df8f0050cc276f0b45c8d0f9f3de0fa1006 [file] [log] [blame]
Brad Bishopff7bf4b2017-01-17 09:14:15 -05001SUMMARY = "Phosphor IPMI Inventory Plugin"
2DESCRIPTION = "A Phosphor IPMI plugin that updates inventory."
Chris Austenf7cefb12015-11-01 22:27:34 -06003PR = "r1"
4
Matthew Barth2c455f02016-10-19 16:00:49 -05005inherit autotools pkgconfig
Brad Bishop0fe80462016-08-17 20:27:37 -04006inherit obmc-phosphor-systemd
Tom Joseph40b4e3f2017-02-01 19:47:27 +05307inherit obmc-phosphor-ipmiprovider-symlink
Brad Bishop2c5db6a2017-01-28 13:00:52 -05008inherit phosphor-ipmi-fru
9inherit pythonnative
Chris Austenf7cefb12015-11-01 22:27:34 -060010
Brad Bishopee064612017-01-17 10:10:02 -050011require ${PN}.inc
12
Brad Bishopdd2e4fa2016-06-13 12:53:41 -040013DEPENDS += " \
Brad Bishop2c5db6a2017-01-28 13:00:52 -050014 virtual/phosphor-ipmi-fru-hostfw-config\
15 virtual/phosphor-ipmi-fru-inventory \
Brad Bishopdd2e4fa2016-06-13 12:53:41 -040016 systemd \
Deepak Kodihalli5df911b2017-02-16 07:50:37 -060017 sdbusplus \
Brad Bishop2c5db6a2017-01-28 13:00:52 -050018 python-mako-native \
19 python-pyyaml-native \
Brad Bishopc30d7bb2017-01-17 10:07:14 -050020 phosphor-ipmi-host \
Matthew Barth2c455f02016-10-19 16:00:49 -050021 phosphor-mapper \
22 autoconf-archive-native \
Brad Bishopdd2e4fa2016-06-13 12:53:41 -040023 "
Chris Austenf7cefb12015-11-01 22:27:34 -060024
Deepak Kodihalli5df911b2017-02-16 07:50:37 -060025RDEPENDS_${PN} += " \
26 sdbusplus \
27 "
Chris Austenf7cefb12015-11-01 22:27:34 -060028
Brad Bishop0fe80462016-08-17 20:27:37 -040029SYSTEMD_SERVICE_${PN} += "obmc-read-eeprom@.service"
Chris Austenf7cefb12015-11-01 22:27:34 -060030
Chris Austenf7cefb12015-11-01 22:27:34 -060031S = "${WORKDIR}/git"
32
Tom Joseph40b4e3f2017-02-01 19:47:27 +053033HOSTIPMI_PROVIDER_LIBRARY += "libstrgfnhandler.so"
34
35FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Matthew Barth2c455f02016-10-19 16:00:49 -050036FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053037FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Brad Bishop2c5db6a2017-01-28 13:00:52 -050038
39# TODO: Fix the the ipmi-fru-parser code generator to handle split
40# host firmware / inventory YAML and replace the OECONF below with:
41#
42# EXTRA_OECONF += "INVENTORY_YAML=${inventory_datadir}/config.yaml"
43# EXTRA_OECONF += "HOSTFW_YAML=${hostfw_datadir}/config.yaml"
44#
45# For now the generator requires them to already be combined so we have:
46EXTRA_OECONF = "YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/config.yaml"