blob: efe0d3864bc1d23468894f1f755ebacd4230c1b9 [file] [log] [blame]
Ed Tanous2fe7ba02018-05-31 15:07:49 -07001SUMMARY = "Phosphor OpenBMC KCS to DBUS"
2DESCRIPTION = "Phosphor OpenBMC KCS to DBUS."
3PR = "r1"
4
Yong Lib8bfdc02018-12-04 21:40:17 +08005LICENSE = "Apache-2.0"
Ed Tanous2fe7ba02018-05-31 15:07:49 -07006LIC_FILES_CHKSUM = "file://LICENSE;md5=b1beb00e508e89da1ed2a541934f28c0"
7
8inherit autotools pkgconfig
Vernon Maueryed16aac2019-03-22 12:25:14 -07009inherit systemd
Ed Tanous2fe7ba02018-05-31 15:07:49 -070010
11PV = "1.0+git${SRCPV}"
12
13KCS_DEVICE ?= "ipmi-kcs3"
14
Vernon Maueryed16aac2019-03-22 12:25:14 -070015SYSTEMD_SERVICE_${PN} = " ${PN}@${KCS_DEVICE}.service "
16FILES_${PN} += " ${systemd_system_unitdir}/${PN}@.service "
Ed Tanous2fe7ba02018-05-31 15:07:49 -070017
18PROVIDES += "virtual/obmc-host-ipmi-hw"
19RPROVIDES_${PN} += "virtual-obmc-host-ipmi-hw"
20RRECOMMENDS_${PN} += "phosphor-ipmi-host"
21
22DEPENDS += " \
23 autoconf-archive-native \
24 systemd \
Vernon Mauery6f174932019-04-12 14:06:06 -070025 sdbusplus \
26 boost \
27 phosphor-logging \
28 cli11 \
Ed Tanous2fe7ba02018-05-31 15:07:49 -070029 "
Ed Tanous2fe7ba02018-05-31 15:07:49 -070030
31S = "${WORKDIR}/git"
Patrick Venture2180ac82019-04-07 07:30:36 -070032SRC_URI = "git://github.com/openbmc/kcsbridge.git"
Andrew Geissler45bee3a2020-06-04 23:41:29 +000033SRCREV = "d8594e9a62feb8b2fac789159966b4782b4aa31e"