blob: f9498011cab216c79e02155da436673b541a2cc6 [file] [log] [blame]
Gunnar Mills35591d42017-01-27 13:13:24 -06001SUMMARY = "Phosphor Software Management"
2DESCRIPTION = "Phosphor Software Manager provides a set of system software \
3management daemons. It is suitable for use on a wide variety of OpenBMC \
4platforms."
Gunnar Mills35591d42017-01-27 13:13:24 -06005PR = "r1"
Matt Spinler3578d902018-06-21 14:23:47 -05006
7require ${PN}.inc
Gunnar Mills35591d42017-01-27 13:13:24 -06008
9SOFTWARE_MGR_PACKAGES = " \
10 ${PN}-version \
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050011 ${PN}-download-mgr \
Gunnar Mills30131f72017-05-15 15:40:58 -050012 ${PN}-updater \
Adriana Kobylak3aeee112018-06-04 13:06:52 -050013 ${PN}-updater-ubi \
Adriana Kobylakaabb95d2018-04-20 14:52:40 -050014 ${PN}-sync \
Gunnar Mills35591d42017-01-27 13:13:24 -060015"
Brad Bishop36a2dfb2018-04-11 11:42:17 -040016PACKAGE_BEFORE_PN += "${SOFTWARE_MGR_PACKAGES}"
17ALLOW_EMPTY_${PN} = "1"
Brad Bishop4c43bb52017-03-01 15:37:17 -050018
Gunnar Mills35591d42017-01-27 13:13:24 -060019DBUS_PACKAGES = "${SOFTWARE_MGR_PACKAGES}"
20
21# Set SYSTEMD_PACKAGES to empty because we do not want ${PN} and DBUS_PACKAGES
22# handles the rest.
23SYSTEMD_PACKAGES = ""
24
Adriana Kobylaka3641d72018-03-29 15:16:09 -050025PACKAGECONFIG[verify_signature] = "--enable-verify_signature,--disable-verify_signature"
Adriana Kobylakaabb95d2018-04-20 14:52:40 -050026PACKAGECONFIG[sync_bmc_files] = "--enable-sync_bmc_files,--disable-sync_bmc_files"
Lei YUdae52f32018-05-23 10:53:24 +080027PACKAGECONFIG[ubifs_layout] = "--enable-ubifs_layout"
Adriana Kobylaka3641d72018-03-29 15:16:09 -050028
Gunnar Mills35591d42017-01-27 13:13:24 -060029inherit autotools pkgconfig
30inherit obmc-phosphor-dbus-service
Gunnar Millse0178ae2017-05-24 13:12:22 -050031inherit pythonnative
Adriana Kobylak3aeee112018-06-04 13:06:52 -050032inherit ${@bb.utils.contains('DISTRO_FEATURES', 'obmc-ubi-fs', 'phosphor-software-manager-ubi-fs', '', d)}
Gunnar Mills35591d42017-01-27 13:13:24 -060033
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050034DEPENDS += " \
35 autoconf-archive-native \
36 sdbusplus \
37 phosphor-dbus-interfaces \
38 phosphor-logging \
Saqib Khan5ef4efb2017-11-15 05:31:12 -060039 sdbus++-native \
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050040"
Gunnar Mills35591d42017-01-27 13:13:24 -060041
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050042RDEPENDS_${PN}-version += " \
43 phosphor-logging \
44 phosphor-dbus-interfaces \
45 sdbusplus \
46"
47RDEPENDS_${PN}-download-mgr += " \
48 phosphor-logging \
49 phosphor-dbus-interfaces \
50 sdbusplus \
51"
Gunnar Mills30131f72017-05-15 15:40:58 -050052RDEPENDS_${PN}-updater += " \
Lei YUb2c944f2018-07-23 13:26:15 +080053 bash \
Gunnar Mills30131f72017-05-15 15:40:58 -050054 phosphor-logging \
55 phosphor-dbus-interfaces \
56 sdbusplus \
Patrick Williams2182d312017-08-09 17:36:04 -050057 virtual-obmc-image-manager \
Lei YUad84f762018-05-11 17:26:35 +080058"
Patrick Williams2182d312017-08-09 17:36:04 -050059
60RPROVIDES_${PN}-version += " \
61 virtual-obmc-image-manager \
Gunnar Mills30131f72017-05-15 15:40:58 -050062"
Gunnar Mills35591d42017-01-27 13:13:24 -060063
Brad Bishop33e5a8b2018-06-08 10:20:52 -040064FILES_${PN}-version += "${sbindir}/phosphor-version-software-manager ${exec_prefix}/lib/tmpfiles.d/software.conf"
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050065FILES_${PN}-download-mgr += "${sbindir}/phosphor-download-manager"
Lei YUb2c944f2018-07-23 13:26:15 +080066FILES_${PN}-updater += " \
67 ${sbindir}/phosphor-image-updater \
68 ${sbindir}/obmc-flash-bmc \
69 "
Adriana Kobylaka420efc2018-05-22 12:33:45 -050070FILES_${PN}-sync += " \
71 ${sbindir}/phosphor-sync-software-manager \
72 ${sysconfdir}/synclist \
73 "
Gunnar Mills4a993b52017-05-11 08:27:12 -050074DBUS_SERVICE_${PN}-version += "xyz.openbmc_project.Software.Version.service"
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050075DBUS_SERVICE_${PN}-download-mgr += "xyz.openbmc_project.Software.Download.service"
Gunnar Mills30131f72017-05-15 15:40:58 -050076DBUS_SERVICE_${PN}-updater += "xyz.openbmc_project.Software.BMC.Updater.service"
Adriana Kobylakaabb95d2018-04-20 14:52:40 -050077DBUS_SERVICE_${PN}-sync += "xyz.openbmc_project.Software.Sync.service"
Gunnar Mills35591d42017-01-27 13:13:24 -060078
Lei YUb2c944f2018-07-23 13:26:15 +080079SYSTEMD_SERVICE_${PN}-updater += " \
80 obmc-flash-bmc-setenv@.service \
81"
82
Brad Bishop33e5a8b2018-06-08 10:20:52 -040083SRC_URI += "file://software.conf"
Lei YUb2c944f2018-07-23 13:26:15 +080084SRC_URI += "file://obmc-flash-bmc"
Brad Bishop33e5a8b2018-06-08 10:20:52 -040085
Adriana Kobylaka290eff2017-06-27 09:39:57 -050086do_install_append() {
Lei YUb2c944f2018-07-23 13:26:15 +080087 install -d ${D}${sbindir}
88 install -m 0755 ${WORKDIR}/obmc-flash-bmc ${D}${sbindir}/obmc-flash-bmc
89
Brad Bishop33e5a8b2018-06-08 10:20:52 -040090 # /tmp/images is the software image upload directory.
91 # It should not be deleted since it is watched by the Image Manager
92 # for new images.
93
94 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true', 'false', d)}; then
95 install -d ${D}${exec_prefix}/lib/tmpfiles.d
96 install -m 644 ${WORKDIR}/software.conf ${D}${exec_prefix}/lib/tmpfiles.d/
97 fi
Adriana Kobylaka290eff2017-06-27 09:39:57 -050098}
99
Gunnar Mills35591d42017-01-27 13:13:24 -0600100S = "${WORKDIR}/git"