Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 1 | SUMMARY = "C++ bindings for systemd dbus APIs" |
| 2 | DESCRIPTION = "C++ bindings for systemd dbus APIs." |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 3 | |
| 4 | inherit autotools pkgconfig |
Patrick Williams | 11d5972 | 2020-02-24 16:29:47 -0600 | [diff] [blame] | 5 | inherit obmc-phosphor-python3-autotools |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 6 | |
Patrick Williams | 2544884 | 2020-03-31 12:51:05 -0500 | [diff] [blame] | 7 | include sdbusplus-rev.inc |
| 8 | |
Patrick Williams | 1914bbb | 2020-05-19 06:56:04 -0500 | [diff] [blame] | 9 | LICENSE = "Apache-2.0" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
Nagaraju Goruganti | 78077a5 | 2017-08-22 05:24:26 -0500 | [diff] [blame] | 14 | DEPENDS += " \ |
| 15 | autoconf-archive-native \ |
Patrick Williams | 4cd2243 | 2020-02-24 16:27:10 -0600 | [diff] [blame] | 16 | ${PYTHON_PN}-inflection-native \ |
| 17 | ${PYTHON_PN}-mako-native \ |
| 18 | ${PYTHON_PN}-pyyaml-native \ |
Nagaraju Goruganti | 78077a5 | 2017-08-22 05:24:26 -0500 | [diff] [blame] | 19 | " |
Brad Bishop | 32f0a9a | 2017-01-18 13:59:33 -0500 | [diff] [blame] | 20 | |
Patrick Williams | 3e13720 | 2020-05-19 07:04:55 -0500 | [diff] [blame] | 21 | PACKAGECONFIG ??= "libsdbusplus" |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 22 | PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd" |
| 23 | |
Patrick Williams | 7aba815 | 2020-03-31 14:22:32 -0500 | [diff] [blame] | 24 | # Remove unused sdbus++ contents (included in python3-sdbus++ package). |
| 25 | do_install_append() { |
| 26 | rm ${D}/${bindir}/sdbus++ |
| 27 | rmdir ${D}/${bindir} || true |
| 28 | rm -rf ${D}/${PYTHON_SITEPACKAGES_DIR} |
| 29 | rmdir ${D}/${libdir}/${PYTHON_DIR} || true |
| 30 | } |