blob: d512c85704c97c6f4358b31fbe09b4bfdcf9b945 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Security-focused ELF files checking tool"
2DESCRIPTION = "This is a small set of various PaX aware and related \
3utilities for ELF binaries. It can check ELF binary files and running \
4processes for issues that might be relevant when using ELF binaries \
5along with PaX, such as non-PIC code or executable stack and heap."
6HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "GPL-2.0-or-later"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
9
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010SRC_URI = "https://dev.gentoo.org/~vapier/dist/pax-utils-${PV}.tar.xz"
Patrick Williams03907ee2022-05-01 06:28:52 -050011SRC_URI[sha256sum] = "eeca7fbd98bc66bead4a77000c2025d9f17ea8201b84245882406ce00b9b6b14"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012
Patrick Williams213cb262021-08-07 19:21:33 -050013RDEPENDS:${PN} += "bash"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014
15export GNULIB_OVERRIDES_WINT_T = "0"
16
Patrick Williams213cb262021-08-07 19:21:33 -050017do_configure:prepend() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018 touch ${S}/NEWS ${S}/AUTHORS ${S}/ChangeLog ${S}/README
19}
20
21do_install() {
22 oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install
23}
24
25BBCLASSEXTEND = "native"
26
27inherit autotools pkgconfig
28
29PACKAGECONFIG ??= ""
30
31PACKAGECONFIG[libcap] = "--with-caps, --without-caps, libcap"
32PACKAGECONFIG[libseccomp] = "--with-seccomp, --without-seccomp, libseccomp"
33PACKAGECONFIG[pyelftools] = "--with-python, --without-python,, pyelftools"
34
35EXTRA_OECONF += "--enable-largefile"