blob: d5137f80afd7ee90cd8ff7aa4c38db9cc2fcf3c2 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "PAM searchless LDAP authentication module"
2HOMEPAGE = "https://github.com/rmbreak/pam_ldapdb"
3BUGTRACKER = "https://github.com/rmbreak/pam_ldapdb/issues"
4SECTION = "libs"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=41ab94182d94be9bb35e2a8b933f1e7d"
7
8DEPENDS = "libpam openldap"
9
Brad Bishop8410d612019-11-25 09:40:59 -050010inherit features_check
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011REQUIRED_DISTRO_FEATURES = "pam"
12
Patrick Williams03907ee2022-05-01 06:28:52 -050013SRCREV = "3e026863cad1fd45c760ee1bc93ef4f0606cc852"
14SRC_URI = "git://github.com/rmbreak/pam_ldapdb;branch=master;protocol=https"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
Brad Bishop26bdd442019-08-16 17:08:17 -040016S = "${WORKDIR}/git"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017
18do_install () {
19 oe_runmake install DESTDIR=${D} PAMDIR=${base_libdir}/security
20}
21
Patrick Williams213cb262021-08-07 19:21:33 -050022FILES:${PN} += "${base_libdir}/security/pam_ldapdb.so"