blob: c82b529f9697e0fc33446492ae75a0ec6d9d0497 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Administration program for the grsecurity RBAC syste"
2DESCRIPTION = "\
3gradm is the userspace RBAC parsing and authentication program for \
4grsecurity grsecurity aims to be a complete security system. gradm \
5performs several tasks for the RBAC system including authenticated \
6via a password to the kernel and parsing rules to be passed to the \
7kernel"
8HOMEPAGE = "http://grsecurity.net/index.php"
9SECTION = "admin"
Andrew Geissler9aee5002022-03-30 16:27:02 +000010LICENSE = "GPL-2.0-only"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011LIC_FILES_CHKSUM = "file://LICENSE;md5=4641e94ec96f98fabc56ff9cc48be14b"
12DEPENDS = "flex-native bison-native ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
13
Brad Bishop26bdd442019-08-16 17:08:17 -040014SRC_URI = "http://grsecurity.net/stable/${BP}.tar.gz \
Brad Bishop7f28bc52017-12-03 23:42:40 -050015 file://0001-Makefile-remove-strip.patch \
16 file://0001-Makefile-Append-instead-of-overriding-LDFLAGS.patch \
Patrick Williams03907ee2022-05-01 06:28:52 -050017 file://0001-make-Define-SBINDIR-flag.patch \
Brad Bishop7f28bc52017-12-03 23:42:40 -050018 "
Patrick Williams03907ee2022-05-01 06:28:52 -050019SRC_URI[sha256sum] = "2459290f367a47c8a1ce4ea2ec08359799ea33dc15ed4436439596ce88284fb9"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020
21S = "${WORKDIR}/gradm"
22
23inherit autotools-brokensep
24
25do_compile() {
26 oe_runmake 'CC=${CC}' \
Brad Bishop26bdd442019-08-16 17:08:17 -040027 'LIBS=' \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050028 'OPT_FLAGS=${CFLAGS}' \
29 'LLEX=${STAGING_BINDIR_NATIVE}/lex' \
30 'FLEX=${STAGING_BINDIR_NATIVE}/flex' \
31 'BISON=${STAGING_BINDIR_NATIVE}/bison' \
32 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', ' ', 'nopam', d)}
33}
34
35do_install() {
36 oe_runmake 'CC=${CC}' \
37 'DESTDIR=${D}' \
Patrick Williams03907ee2022-05-01 06:28:52 -050038 'SBINDIR=${base_sbindir}' \
Brad Bishop26bdd442019-08-16 17:08:17 -040039 'LIBS=' \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050040 'LLEX=${STAGING_BINDIR_NATIVE}/lex' \
41 'FLEX=${STAGING_BINDIR_NATIVE}/flex' \
42 'BISON=${STAGING_BINDIR_NATIVE}/bison' \
43 install
44
45 # The device nodes are generated by postinstall or udev
46 rm -rf ${D}/dev
47}
48
Patrick Williams213cb262021-08-07 19:21:33 -050049pkg_postinst_ontarget:${PN}() {
Patrick Williamsb48b7b42016-08-17 15:04:38 -050050 /bin/mknod -m 0622 /dev/grsec c 1 13
51}