blob: d0de035921f6876c8505ba72953e6ce08a7a6d0d [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "This is a simple example recipe that cross-compiles a Go program."
2SECTION = "examples"
3HOMEPAGE = "https://golang.org/"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05004
Brad Bishopd7bf8c12018-02-25 22:55:05 -05005LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007
Andrew Geissler595f6302022-01-24 19:11:47 +00008SRC_URI = "git://go.googlesource.com/example;branch=master;protocol=https"
Patrick Williams03907ee2022-05-01 06:28:52 -05009SRCREV = "2e68773dfca072cb81f219fc3b97ad34fe9d9f94"
Brad Bishop316dfdd2018-06-25 12:45:53 -040010UPSTREAM_CHECK_COMMITS = "1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011
Andrew Geissler595f6302022-01-24 19:11:47 +000012GO_IMPORT = "golang.org/x/example"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013GO_INSTALL = "${GO_IMPORT}/hello"
Patrick Williams03907ee2022-05-01 06:28:52 -050014
Andrew Geissler95ac1b82021-03-31 14:34:31 -050015export GO111MODULE="off"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016
Andrew Geissler95ac1b82021-03-31 14:34:31 -050017inherit go
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018
19# This is just to make clear where this example is
Patrick Williams213cb262021-08-07 19:21:33 -050020do_install:append() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021 mv ${D}${bindir}/hello ${D}${bindir}/${BPN}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050022}