Zane Shelley | 6714373 | 2021-03-23 17:08:45 -0500 | [diff] [blame] | 1 | SUMMARY = "Hardware Diagnostics for POWER Systems" |
Brad Bishop | fac997f | 2020-02-03 17:09:22 -0500 | [diff] [blame] | 2 | |
Zane Shelley | 6714373 | 2021-03-23 17:08:45 -0500 | [diff] [blame] | 3 | DESCRIPTION = \ |
| 4 | "In the event of a system fatal error reported by the internal system \ |
| 5 | hardware (processor chips, memory chips, I/O chips, system memory, etc.), \ |
| 6 | POWER Systems have the ability to diagnose the root cause of the failure \ |
| 7 | and perform any service action needed to avoid repeated system failures." |
| 8 | |
Zane Shelley | 92804a7 | 2021-06-04 17:18:22 -0500 | [diff] [blame] | 9 | HOMEPAGE = "https://github.com/openbmc/openpower-hw-diags" |
| 10 | |
Brad Bishop | fac997f | 2020-02-03 17:09:22 -0500 | [diff] [blame] | 11 | LICENSE = "Apache-2.0" |
| 12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 13 | |
Zane Shelley | 92804a7 | 2021-06-04 17:18:22 -0500 | [diff] [blame] | 14 | PR = "r1" |
| 15 | PV = "0.1+git${SRCPV}" |
Brad Bishop | fac997f | 2020-02-03 17:09:22 -0500 | [diff] [blame] | 16 | |
Patrick Williams | bb99d22 | 2022-01-24 15:55:09 -0600 | [diff] [blame] | 17 | SRC_URI = "git://github.com/openbmc/openpower-hw-diags;branch=master;protocol=https" |
Andrew Geissler | e695c3b | 2022-07-12 15:20:35 -0500 | [diff] [blame] | 18 | SRCREV = "a9f85590e8e39f1a66f0160d8ac63910c030d0af" |
Zane Shelley | 6714373 | 2021-03-23 17:08:45 -0500 | [diff] [blame] | 19 | |
Zane Shelley | 92804a7 | 2021-06-04 17:18:22 -0500 | [diff] [blame] | 20 | S = "${WORKDIR}/git" |
| 21 | |
Andrew Geissler | baf5ba7 | 2021-11-03 10:01:23 -0500 | [diff] [blame] | 22 | inherit pkgconfig meson systemd |
Zane Shelley | 92804a7 | 2021-06-04 17:18:22 -0500 | [diff] [blame] | 23 | |
Adriana Kobylak | 8c6707f | 2021-08-06 17:35:36 +0000 | [diff] [blame] | 24 | SYSTEMD_SERVICE:${PN} = "attn_handler.service" |
Zane Shelley | 6714373 | 2021-03-23 17:08:45 -0500 | [diff] [blame] | 25 | |
Zane Shelley | b6d95ee | 2021-02-10 17:43:44 -0600 | [diff] [blame] | 26 | DEPENDS = "boost libgpiod pdbg phosphor-logging sdbusplus openpower-libhei \ |
Zane Shelley | 75174d3 | 2022-02-01 17:04:08 -0600 | [diff] [blame] | 27 | nlohmann-json valijson fmt" |
Zane Shelley | b6d95ee | 2021-02-10 17:43:44 -0600 | [diff] [blame] | 28 | |
Zane Shelley | 8dff99b | 2020-11-10 19:56:40 -0600 | [diff] [blame] | 29 | # This is required so that libhei is installed with the chip data files. |
Adriana Kobylak | 8c6707f | 2021-08-06 17:35:36 +0000 | [diff] [blame] | 30 | RDEPENDS:${PN} += "openpower-libhei" |
Zane Shelley | aa8acf1 | 2021-03-23 17:13:08 -0500 | [diff] [blame] | 31 | |
| 32 | # Conditionally pull in PHAL APIs, if available. |
Patrick Williams | 8c561ee | 2021-10-22 14:20:12 -0500 | [diff] [blame] | 33 | PACKAGECONFIG ??= "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}" |
Ben Tyner | 2ded481 | 2021-10-12 15:20:11 -0500 | [diff] [blame] | 34 | PACKAGECONFIG[phal] = "-Dphal=enabled, -Dphal=disabled, ipl pdata" |
Zane Shelley | aa8acf1 | 2021-03-23 17:13:08 -0500 | [diff] [blame] | 35 | |
Zane Shelley | 896d142 | 2022-01-14 13:09:44 -0600 | [diff] [blame] | 36 | # Don't build CI tests |
| 37 | EXTRA_OEMESON = "-Dtests=disabled" |
| 38 | |