blob: 4c7237fcac64b718081bf7a58dcbf377e1a8def0 [file] [log] [blame]
Rick Altherr4d9fd232016-12-08 12:21:49 -08001DESCRIPTION = "Small image capable of booting a device. The kernel includes \
2the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
3first 'init' program more efficiently."
4
Adriana Kobylak0998d1e2020-06-03 16:22:42 -05005# Init scripts
6INIT_PACKAGE = "obmc-phosphor-initfs"
7INIT_PACKAGE_df-phosphor-mmc = "phosphor-mmc-init"
8
9PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} ${INIT_PACKAGE}"
Rick Altherr4d9fd232016-12-08 12:21:49 -080010
11# Do not pollute the initrd image with rootfs features
William A. Kennington III60301252019-09-23 12:27:48 -070012IMAGE_FEATURES = "read-only-rootfs"
Rick Altherr4d9fd232016-12-08 12:21:49 -080013
14export IMAGE_BASENAME = "obmc-phosphor-initramfs"
15IMAGE_LINGUAS = ""
16
17LICENSE = "MIT"
18
19IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
20inherit core-image
21
22IMAGE_ROOTFS_SIZE = "8192"
23IMAGE_ROOTFS_EXTRA_SPACE = "0"
24
William A. Kennington III12c132f2019-09-23 12:26:55 -070025# Needed for the set_user_group functions to succeed
26DEPENDS += "shadow-native"
27
Richard Marian Thomaiyar48423842018-10-03 10:47:25 +053028PACKAGE_INSTALL_remove = "shadow"
29PACKAGE_EXCLUDE = "shadow"
Rick Altherr4d9fd232016-12-08 12:21:49 -080030BAD_RECOMMENDATIONS += "busybox-syslog"