blob: 97a9027af4e87e692329ea7e1a16b6375a956a25 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A sophisticated network protocol analyzer"
2HOMEPAGE = "http://www.tcpdump.org/"
Brad Bishop19323692019-04-05 15:28:33 -04003SECTION = "net"
Brad Bishop2d39a062019-10-28 08:33:36 -04004LICENSE = "BSD-3-Clause"
Andrew Geissler97771a32021-03-05 15:23:11 -06005LIC_FILES_CHKSUM = "file://LICENSE;md5=5eb289217c160e2920d2e35bddc36453"
Brad Bishop19323692019-04-05 15:28:33 -04006
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007DEPENDS = "libpcap"
8
Patrick Williams213cb262021-08-07 19:21:33 -05009RDEPENDS:${PN}-ptest += " make perl \
Brad Bishop63ae8782019-10-09 09:56:13 -040010 perl-module-file-basename \
Andrew Geissler97771a32021-03-05 15:23:11 -060011 perl-module-file-spec \
12 perl-module-file-spec-unix \
13 perl-module-file-path \
14 perl-module-file-glob \
15 perl-module-data-dumper \
16 perl-module-bytes \
Brad Bishop63ae8782019-10-09 09:56:13 -040017 perl-module-posix \
Andrew Geissler97771a32021-03-05 15:23:11 -060018 perl-module-carp \
19 perl-module-cwd \
20 perl-module-constant \
21"
Brad Bishop63ae8782019-10-09 09:56:13 -040022
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023SRC_URI = " \
24 http://www.tcpdump.org/release/${BP}.tar.gz \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025 file://add-ptest.patch \
26 file://run-ptest \
Andrew Geissler97771a32021-03-05 15:23:11 -060027 file://0001-aclocal.m4-Skip-checking-for-pcap-config.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028"
29
Andrew Geissler97771a32021-03-05 15:23:11 -060030SRC_URI[md5sum] = "b10aa2f497def7283bc060f626879ce5"
31SRC_URI[sha256sum] = "8cf2f17a9528774a7b41060323be8b73f76024f7778f59c34efa65d49d80b842"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050032
Andrew Geissler72956ed2021-01-08 16:11:14 -060033UPSTREAM_CHECK_REGEX = "tcpdump-(?P<pver>\d+(\.(?!99)\d+)+)\.tar"
34
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035inherit autotools-brokensep ptest
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036
Brad Bishop19323692019-04-05 15:28:33 -040037PACKAGECONFIG ?= "openssl"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050038
Brad Bishop19323692019-04-05 15:28:33 -040039PACKAGECONFIG[libcap-ng] = "--with-cap-ng,--without-cap-ng,libcap-ng"
Andrew Geissler7f40b712020-05-15 14:09:53 -050040PACKAGECONFIG[openssl] = "--with-crypto,--without-crypto,openssl"
Brad Bishop19323692019-04-05 15:28:33 -040041PACKAGECONFIG[smi] = "--with-smi,--without-smi,libsmi"
Brad Bishop63ae8782019-10-09 09:56:13 -040042# Note: CVE-2018-10103 (SMB - partially fixed, but SMB printing disabled)
43PACKAGECONFIG[smb] = "--enable-smb,--disable-smb"
Brad Bishop19323692019-04-05 15:28:33 -040044
45EXTRA_AUTORECONF += "-I m4"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050046
Patrick Williams213cb262021-08-07 19:21:33 -050047do_configure:prepend() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050048 mkdir -p ${S}/m4
49 if [ -f aclocal.m4 ]; then
50 mv aclocal.m4 ${S}/m4
51 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050052}
53
Patrick Williams213cb262021-08-07 19:21:33 -050054do_install:append() {
Brad Bishop19323692019-04-05 15:28:33 -040055 # make install installs an unneeded extra copy of the tcpdump binary
Andrew Geissler97771a32021-03-05 15:23:11 -060056 rm ${D}${bindir}/tcpdump.${PV}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050057}
58
59do_compile_ptest() {
60 oe_runmake buildtest-TESTS
61}