Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "LogFS Programs: used to create LogFS file system" |
| 2 | DESCRIPTION = "\ |
| 3 | LogFS is a Linux log-structured and scalable flash file system, intended \ |
| 4 | for use on large devices of flash memory. It is written by Jörn Engel and \ |
| 5 | in part sponsored by the CE Linux Forum. \ |
| 6 | LogFS is included in the mainline Linux kernel and was introduced in \ |
| 7 | version 2.6.34, released on May 16, 2010." |
| 8 | HOMEPAGE = "https://github.com/prasad-joshi/logfsprogs" |
| 9 | SECTION = "base" |
| 10 | LICENSE = "GPLv2" |
| 11 | LIC_FILES_CHKSUM = "file://fsck.c;md5=3859dc73da97909ff1d0125e88a27e02" |
| 12 | DEPENDS = "zlib" |
| 13 | |
Brad Bishop | 7f28bc5 | 2017-12-03 23:42:40 -0500 | [diff] [blame] | 14 | SRC_URI = "git://github.com/prasad-joshi/logfsprogs.git \ |
| 15 | file://0001-Add-LDFLAGS-to-linker-cmdline.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 16 | file://0001-btree-Avoid-conflicts-with-libc-namespace-about-setk.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | file://0001-include-sys-sysmacros.h-for-major-minor-definition.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 18 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 19 | SRCREV = "45b72c81ce3c6fa17ca19bafc207ea93e76312f4" |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | EXTRA_OEMAKE = "CC="${CC}" LD="${LD}" AR="${AR}"" |
| 24 | |
| 25 | do_install () { |
| 26 | mkdir -p ${D}${bindir} |
| 27 | install -m 0755 ${S}/mklogfs ${D}${bindir}/mklogfs |
| 28 | } |
| 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |