blob: d9864ac3e87bbbb5236f6bc9e0e96777196b0669 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "LogFS Programs: used to create LogFS file system"
2DESCRIPTION = "\
3LogFS is a Linux log-structured and scalable flash file system, intended \
4for use on large devices of flash memory. It is written by Jörn Engel and \
5in part sponsored by the CE Linux Forum. \
6LogFS is included in the mainline Linux kernel and was introduced in \
7version 2.6.34, released on May 16, 2010."
8HOMEPAGE = "https://github.com/prasad-joshi/logfsprogs"
9SECTION = "base"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://fsck.c;md5=3859dc73da97909ff1d0125e88a27e02"
12DEPENDS = "zlib"
13
Brad Bishop7f28bc52017-12-03 23:42:40 -050014SRC_URI = "git://github.com/prasad-joshi/logfsprogs.git \
15 file://0001-Add-LDFLAGS-to-linker-cmdline.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016 file://0001-btree-Avoid-conflicts-with-libc-namespace-about-setk.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017 file://0001-include-sys-sysmacros.h-for-major-minor-definition.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050019SRCREV = "45b72c81ce3c6fa17ca19bafc207ea93e76312f4"
20
21S = "${WORKDIR}/git"
22
23EXTRA_OEMAKE = "CC="${CC}" LD="${LD}" AR="${AR}""
24
25do_install () {
26 mkdir -p ${D}${bindir}
27 install -m 0755 ${S}/mklogfs ${D}${bindir}/mklogfs
28}
29
30BBCLASSEXTEND = "native nativesdk"