blob: 09a5582aae99a5d09bb844574f27a04f5154e1eb [file] [log] [blame]
Brad Bishop93fb5352015-09-09 03:59:20 +00001# Common code for dbus applications using python.
2
3inherit allarch
4inherit obmc-phosphor-systemd
Brad Bishop93fb5352015-09-09 03:59:20 +00005
Patrick Williams12fc9392021-08-06 09:16:53 -05006RDEPENDS:${PN} += "python3-dbus python3-pygobject"
Brad Bishop51607d22015-10-18 22:00:15 -04007INSTALL_NAME ?= "${PN}"
8SCRIPT_NAME ?= "${INSTALL_NAME}.py"
Brad Bishop93fb5352015-09-09 03:59:20 +00009
Patrick Williams12fc9392021-08-06 09:16:53 -050010do_install:append() {
Brad Bishop93fb5352015-09-09 03:59:20 +000011 # install the script
12 install -d ${D}${sbindir}
Brad Bishop51607d22015-10-18 22:00:15 -040013 install -m 0755 ${S}/${SCRIPT_NAME} ${D}${sbindir}/${INSTALL_NAME}
Brad Bishop93fb5352015-09-09 03:59:20 +000014}