blob: f50b3d59b67558e4425198e5b60a75ecdc80904f [file] [log] [blame]
Kuiying Wang91ff72a2018-11-08 16:52:49 +08001SUMMARY = "OpenBMC Buttons"
2DESCRIPTION = "OpenBMC All buttons"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7
8S = "${WORKDIR}/git"
9SRC_URI += "git://github.com/openbmc/phosphor-buttons.git"
Andrew Geissler95907a32020-05-14 00:50:57 +000010SRCREV = "5ed4cc0f0947e589c430618c29bd474f0fce32b3"
Kuiying Wang91ff72a2018-11-08 16:52:49 +080011
12inherit cmake pkgconfig systemd
13
Matt Spinler9ad66412018-11-26 15:37:30 -060014BUTTON_PACKAGES="${PN}-signals ${PN}-handler"
15
Patrick Williams12fc9392021-08-06 09:16:53 -050016ALLOW_EMPTY:${PN} = "1"
Matt Spinler9ad66412018-11-26 15:37:30 -060017PACKAGE_BEFORE_PN += "${BUTTON_PACKAGES}"
18PACKAGECONFIG ??= "signals handler"
19SYSTEMD_PACKAGES = "${BUTTON_PACKAGES}"
20
21PACKAGECONFIG[signals] = ",,gpioplus nlohmann-json,"
22PACKAGECONFIG[handler] = ",,,phosphor-state-manager-chassis phosphor-state-manager-host"
23
Patrick Williams12fc9392021-08-06 09:16:53 -050024FILES:${PN}-signals = "${bindir}/buttons"
25SYSTEMD_SERVICE:${PN}-signals = "xyz.openbmc_project.Chassis.Buttons.service"
Matt Spinler9ad66412018-11-26 15:37:30 -060026
Patrick Williams12fc9392021-08-06 09:16:53 -050027FILES:${PN}-handler = "${bindir}/button-handler"
28SYSTEMD_SERVICE:${PN}-handler = "phosphor-button-handler.service"
Kuiying Wang91ff72a2018-11-08 16:52:49 +080029
30DEPENDS += " \
31 systemd \
32 sdbusplus \
33 phosphor-dbus-interfaces \
34 phosphor-logging \
Kuiying Wang91ff72a2018-11-08 16:52:49 +080035 "