blob: b50c3acf4cca305ddc3835108f5311b40808e324 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Free and Open On-Chip Debugging, In-System Programming and Boundary-Scan Testing"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4DEPENDS = "libusb-compat libftdi"
5RDEPENDS_${PN} = "libusb1"
6
Brad Bishop757e94a2018-09-07 18:58:51 +00007SRC_URI = " \
8 git://repo.or.cz/openocd.git;protocol=http;name=openocd \
9 git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \
10 git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \
11 git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \
Brad Bishop15ae2502019-06-18 21:44:24 -040012 file://0001-esirisc_flash-Rename-PAGE_SIZE-to-FLASH_PAGE_SIZE.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014
Brad Bishop757e94a2018-09-07 18:58:51 +000015SRCREV_FORMAT = "openocd"
Brad Bishopba6de432019-05-21 08:07:33 -040016SRCREV_openocd = "7ee618692f56b0efea864890da45d73d28e393d9"
Brad Bishop757e94a2018-09-07 18:58:51 +000017SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba"
18SRCREV_jimtcl = "a9bf5975fd0f89974d689a2d9ebd0873c8d64787"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019SRCREV_libjaylink = "8645845c1abebd004e991ba9a7f808f4fd0c608b"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050020
21PV = "0.10+gitr${SRCPV}"
22S = "${WORKDIR}/git"
23
24inherit pkgconfig autotools-brokensep gettext
25
26BBCLASSEXTEND += "nativesdk"
27
Brad Bishop757e94a2018-09-07 18:58:51 +000028EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050029
30do_configure() {
Brad Bishop757e94a2018-09-07 18:58:51 +000031 ./bootstrap nosubmodule
Brad Bishop19323692019-04-05 15:28:33 -040032 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/jimtcl/autosetup
33 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/jimtcl/autosetup
Brad Bishopd7bf8c12018-02-25 22:55:05 -050034 oe_runconf ${EXTRA_OECONF}
35}
36
37do_install() {
38 oe_runmake DESTDIR=${D} install
39 if [ -e "${D}${infodir}" ]; then
40 rm -Rf ${D}${infodir}
41 fi
42 if [ -e "${D}${mandir}" ]; then
43 rm -Rf ${D}${mandir}
44 fi
45 if [ -e "${D}${bindir}/.debug" ]; then
46 rm -Rf ${D}${bindir}/.debug
47 fi
48}
49
50FILES_${PN} = " \
51 ${datadir}/openocd/* \
52 ${bindir}/openocd \
53 "
54
55PACKAGECONFIG[sysfsgpio] = "--enable-sysfsgpio,--disable-sysfsgpio"
56PACKAGECONFIG ??= "sysfsgpio"